1. AC Question's Avatar
    Hi i recently purchased a Gemini 9.7" JoyTab and well its just not working. when it starts up the manufacturers logo shows fine so its not a screen problem, then after a few seconds when android is suppose to boot up the screen flickers black and white with lines running up and down the screen then shuts off. also when it turns off it makes a click noise. i have tried to reset using the hole with a pin and even the volume button & power button combination but theres no response it just starts up like normal then crashes again. Anyone know what this could be?
    08-29-2014 11:08 AM
  2. UJ95x's Avatar
    Hi i recently purchased a Gemini 9.7" JoyTab and well its just not working. when it starts up the manufacturers logo shows fine so its not a screen problem, then after a few seconds when android is suppose to boot up the screen flickers black and white with lines running up and down the screen then shuts off. also when it turns off it makes a click noise. i have tried to reset using the hole with a pin and even the volume button & power button combination but theres no response it just starts up like normal then crashes again. Anyone know what this could be?
    Welcome to AC
    Sounds like a defective device. Where did you buy it?

    Sent from my Galaxy S4 running SlimKat 4.4.4
    08-29-2014 11:48 AM
  3. acoreyr's Avatar
    I got it from a company called Very. they are refusing to send it to get repaired and Gemini are not allowing it to be sent back unless it is through very. the tablet worked for around 2 days then i noticed the distortion and lines would appear now and then, now it just doing it constantly. i thought it was the connection to the screen but the Gemini logo comes up fine then as soon as it changes to the android logo it just flickers with the lines again and shuts off, its really confusing me what it is.
    08-29-2014 12:58 PM
  4. UJ95x's Avatar
    I got it from a company called Very. they are refusing to send it to get repaired and Gemini are not allowing it to be sent back unless it is through very. the tablet worked for around 2 days then i noticed the distortion and lines would appear now and then, now it just doing it constantly. i thought it was the connection to the screen but the Gemini logo comes up fine then as soon as it changes to the android logo it just flickers with the lines again and shuts off, its really confusing me what it is.
    Why are they refusing to send it out for repair?

    Sent from my Galaxy S4 running SlimKat 4.4.4
    08-29-2014 01:02 PM
  5. acoreyr's Avatar
    Very are saying its Gemini's problem and Gemini are saying its Very's problem. both companies are refusing to have the item returned and repaired so im just trying to see if i can get the issue solved before i end up paying £40 for the repair.
    08-29-2014 01:06 PM

Similar Threads

  1. Duplicate Toolbox Icon Permanently Stuck on Screen
    By sfogle in forum Samsung Galaxy S5
    Replies: 10
    Last Post: 03-19-2015, 11:17 AM
  2. Kyocera Hydro stuck on Boost Mobile screen
    By Max Pascua in forum Ask a Question
    Replies: 2
    Last Post: 12-21-2014, 11:16 AM
  3. Sg note 2 getting switched off in 2-3 minutes after software update
    By sanjeevloonker in forum Samsung Galaxy Note 2
    Replies: 1
    Last Post: 08-29-2014, 04:12 PM
  4. Replies: 1
    Last Post: 08-29-2014, 04:02 PM
  5. S5 Screen/Glass issue
    By fdawg in forum Samsung Galaxy S5
    Replies: 3
    Last Post: 08-29-2014, 11:34 AM
LINK TO POST COPIED TO CLIPBOARD