1. AC Question's Avatar
    hi my valiant is frozen with a message saying "update exception EMMC is readonly, yo" is there a way to fix without losing my contacts and pics thank u
    08-30-2014 12:16 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try booting into Recovery and wiping the cache partition, which won't erase any personal data. Follow the steps in this video, but instead of selecting "wipe data/factory reset," make sure you select "wipe cache partition."

    08-31-2014 12:47 AM
  3. Christian Gary's Avatar
    What about if your phone doesn't have an SD Card? I'm only asking because my phone has been messed up in this fashion (frozen on the logo screen after all the apps kept crashing) for the last month or so. So, would there be any help for me to get out of this situation despite not having an SD Card?
    06-04-2015 07:38 AM
  4. korthax's Avatar
    ok, so i boot the valiant up and it gives me multiple apps closing sometimes in a loop so cant do nothing with the phone, or sometimes stops for a short period, then starts back up again..
    a few of the error messages I get are as follows:
    "Unfortunately, the process com.google.process.gapps has stopped"
    "Unfortunately, Google Play services has stopped"
    (the above 2 happen the most)
    "Unfortunately, the process android.process.acore has stopped"
    "Unfortunately, 2D Home has stopped"
    "Unfortunately, Link2SD has stopped"

    I tried using the update.zip with the cwm (phone is rooted with cwm) it shows it works, then reboots and phone is exactly same as started all apps, all everything. I try deleteing apps off the phone, or even installing from playstore with i get a chance to do so without the error messages, it all shows up on phone, it works fine, then reboot and everything back to how it was when booted up in first place, all apps i deleted are back, all apps added are now gone.
    main issue is the original memory card had in here went completely bad, it had all the links for link2sd on it.
    I believe this is a issue with the link2sd that might be causing this issue. I have searched google to best of my ability, but any google search with link2sd in it only tells you how to install it, doesnt give any how to fix when the sdcard is gone. now the phone is on read only and i cant even put a new CWM or a new firmware on it.
    Is the phone now a brick?
    Ok, so here is some more information:
    note: mmcblk0p15 the 0 is a zero

    In CWM:
    advanced -> show log:
    E:Can't open /cache/recovery/log
    mount: mounting /dev/block/mmcblk0p15 on /cache
    failed: invalid argument
    W:failed to mount /dev/block/mmcblk0p15 (File exists)
    E:Can't mount /cache/recovery/last_log
    E:Can't open /cache/recovery/last_log
    mount: mounting /dev/block/mmcblk0p15 on /cache
    failed: invalid argument
    W:failed to mount /dev/block/mmcblk0p15 (File exists)
    E:Can't mount /cache/recovery/last_install
    E:Can't open /cache/recovery/last_install
    mount: mounting /dev/block/mmcblk0p15 on /cache
    failed: invalid argument
    W:failed to mount /dev/block/mmcblk0p15 (File exists)
    W:Can't unlink /cache/recovery/command

    Install Zip:
    -- Installing: /external_sd/Stock.zip
    E:Can't mount /cache/recovery/last_install
    E:failed to open last_install: File exists
    Finding update package...
    Opening update package...
    Installing update...
    *****************************************************
    Stock ROM for Huawei Valiant (No Root)
    Created by: Eagerestwolf
    Stock image provided by: DeadDude
    *****************************************************

    Formatting system...
    Wiping cache and data...
    Installing stock system...
    Setting permissions...
    Installing kernel...
    Installing stock recovery...
    Finishing up...


    Done!

    Install from sdcard complete.
    ** At this point I tap the screen and get this **
    E:Can't mount /cache/recovery/log
    E:Can't open /cache/recovery/log
    E:Can't mount /cache/recovery/last_log
    E:Can't open /cache/recovery/last_log
    E:Can't mount /cache/recovery/last_install
    E:Can't open /cache/recovery/last_install

    wipe data/factory reset
    -- Wiping data...
    Formatting /data...
    Formatting /cache...
    E:Can't mount /cache/recovery/log
    E:Can't open /cache/recovery/log
    E:Can't mount /cache/recovery/last_log
    E:Can't open /cache/recovery/last_log
    E:Can't mount /cache/recovery/last_install
    E:Can't open /cache/recovery/last_install
    Formatting /sd-ext...
    E:unknown volume for path [/sd-ext]
    Formatting /sdcard/.android_secure...
    Error mounting /sdcard/.android_secure!
    Skipping format...
    Data wipe complete.
    E:Can't mount /cache/recovery/log
    E:Can't open /cache/recovery/log
    E:Can't mount /cache/recovery/last_log
    E:Can't open /cache/recovery/last_log
    E:Can't mount /cache/recovery/last_install
    E:Can't open /cache/recovery/last_install

    wipe cache partition
    -- Wiping cache...
    Formatting /cache...
    E:Can't mount /cache/recovery/log
    E:Can't open /cache/recovery/log
    E:Can't mount /cache/recovery/last_log
    E:Can't open /cache/recovery/last_log
    E:Can't mount /cache/recovery/last_install
    E:Can't open /cache/recovery/last_install
    Cache wipe complete.
    E:Can't mount /cache/recovery/log
    E:Can't open /cache/recovery/log
    E:Can't mount /cache/recovery/last_log
    E:Can't open /cache/recovery/last_log
    E:Can't mount /cache/recovery/last_install
    E:Can't open /cache/recovery/last_install

    when in mounts and storage menu
    - mount /cache
    Error mounting /cache!
    - format /cache
    Formatting /cache...
    Done.
    (all other mounts work)
    (Formatting any says "Done.")

    keep in mind it makes zero changes when reboot phone, still same cwm, same applications, etc...

    would maybe a new cache image via fastboot work?
    06-12-2015 09:43 PM
  5. Isaiah Hunter's Avatar
    I'm having the exact same problem as you. The only difference that when I try master resetting my phone the reset fails. I've tried everything from backing up the data then rebooting from hard resetting to getting the firmware Update.App file and tried booting that from the SD card in recovery mode. Really wish someone could help with this.
    11-15-2016 04:19 PM

Similar Threads

  1. multimedia messages
    By sherri pruitt in forum Ask a Question
    Replies: 1
    Last Post: 08-30-2014, 11:41 AM
  2. HTC M8 Messages
    By Nekoxii in forum HTC One M8
    Replies: 3
    Last Post: 08-30-2014, 11:15 AM
  3. Recover old SMS test messages
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-30-2014, 09:24 AM
  4. Goes to docking mode on its own
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-30-2014, 08:45 AM
LINK TO POST COPIED TO CLIPBOARD