1. jtblazer's Avatar
    Saw an article on the Google camera app and thought that I would try it on my note 3. I'm on Verizon running 4.3 and am not rooted. It said it wasn't compatible with my device. Any thoughts as to why?
    09-05-2014 12:14 AM
  2. belodion's Avatar
    It says in the app description that it needs the device to be running Kitkat 4.4 or later.😕

    Posted via Android Central App
    09-05-2014 03:34 PM
  3. jtblazer's Avatar
    Wow.... Can't believe I missed that. Embarrassing moment right there.
    09-06-2014 08:11 AM

Similar Threads

  1. Replies: 0
    Last Post: 09-05-2014, 12:00 AM
  2. Replies: 0
    Last Post: 09-04-2014, 09:20 PM
  3. Replies: 1
    Last Post: 09-04-2014, 08:56 PM
  4. YouTube issue in OK?
    By indiane in forum OnePlus One
    Replies: 1
    Last Post: 09-04-2014, 08:15 PM
  5. Can't install Google Services update
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-04-2014, 07:58 PM
LINK TO POST COPIED TO CLIPBOARD