1. Vic's Avatar
    I have my samsung galaxy xcover for 1,5 year and this issue has started a month ago. Sometimes (especially if I hold power button for a few secs) phone turns off and starts showing loading screen with logo. However, it doesnt go anywhere from here and it just stays there for hours without loading my phone. I can only get rid of it by removing the battery. It woudnt be a big issue if it happened occassionally, but it happens all the time, and phone just turns off and shows flashing loading screen which makes me unable to use it. How can this be fixed? Thanks for any ideas.
    09-08-2014 08:43 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try booting into Recovery Mode and wiping the cache partition, which won't erase any personal data. Follow the steps in this video, but instead of selecting Wipe Data/Factory Reset, make sure you select Wipe Cache Partition. When complete, then select Reboot System Now.

    09-08-2014 10:24 PM

Similar Threads

  1. Replies: 1
    Last Post: 09-08-2014, 10:36 PM
  2. Blocking phone numbers/calls on Samsung Ace GT_S7560M
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-08-2014, 06:37 PM
  3. Sprint galaxy s5 hdmi issues...help!
    By urquhart518 in forum Ask a Question
    Replies: 0
    Last Post: 09-08-2014, 06:37 PM
  4. how to get transparent notification / home button bars on the Galaxy Nexus?
    By Carla97220 in forum Google / Samsung Galaxy Nexus
    Replies: 1
    Last Post: 09-08-2014, 06:23 PM
  5. Replies: 0
    Last Post: 09-08-2014, 06:21 PM
LINK TO POST COPIED TO CLIPBOARD