1. AC Question's Avatar
    Hi, I have a Sprint network Samsung Conquer 4G phone that has worked fine up until today. I went to transfer video files from my phone and my Windows 8.1 OS PC now says the device is not recognized and when I look under Properties for the "unknown device" it says no drivers are installed. I downloaded and set up the .exe files and still nothing. It's driving me batty. Please help. Thanks in advance!
    09-20-2014 05:02 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! So when you connect the phone via USB to your computer, do you actually see it come up as "Unknown Device" in Windows Explorer, or in the Device Manager? If so, right click and select Remove Device. Now unplug the phone from the computer, and then plug it back in, and see if the Plug and Play feature detects the phone as if it were brand new.

    You already tried reinstalling the USB drivers from here, right? Support - Sprint Cell Phones SPH-D600 | Samsung Cell Phones
    09-21-2014 01:25 AM

Similar Threads

  1. Replies: 1
    Last Post: 09-20-2014, 03:27 PM
  2. Did my Samsung update successfully?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-20-2014, 03:22 PM
  3. Samsung Galaxy Note 2 when all else fails
    By Anthony Launey in forum Samsung Galaxy Note 2
    Replies: 1
    Last Post: 09-20-2014, 03:16 PM
  4. Samsung Galaxy Note 2 when all else fails
    By Anthony Launey in forum Samsung Galaxy Note 4
    Replies: 1
    Last Post: 09-20-2014, 03:16 PM
  5. Root Samsung Galaxy Mega
    By Unregistered in forum Ask a Question
    Replies: 1
    Last Post: 09-20-2014, 03:07 PM
LINK TO POST COPIED TO CLIPBOARD