1. mgmchenry's Avatar
    I have a LG G3 and recently purchased an iWerkz folding bluetooth keyboard to go with it (mywerkz.com/iwerkz_bluetooth_keyboard/).

    The keyboard pairs no problem and works great except for one thing: when you get into text entry mode, the on-screen keyboard still displays.

    In text entry mode, a notification to "Choose input method" shows up and from there I can set Hardware/Physical Keyboard to On, then everything works as expected and the on-screen keyboard is not displayed while the bluetooth keyboard is connected. You can also get to the Hardware/Physical Keyboard setting from Settings->Language & Input->Default.

    Unfortunately, whether I change it from the notification or in the Settings menu, the setting doesn't stick. The next time the BT keyboard connects, the Hardware/Physical Keyboard setting is back to Off and I have to manually change it to On.

    It seems like the opposite of what you would expect. And in fact, when searching about this issue I could only find posts with the opposite complaint, where the Hardware/Physical Keyboard setting defaulted to On and they wanted it to default to Off so they could use the on-screen keyboard while the bluetooth keyboard was connected.

    I don't know if the issue is with LG, KitKat, iWerkz or some combination. But for many others it seems like they are seeing the behavior I want by default, so it's pretty frustrating.

    I'm aware of various workarounds using Null Keyboards and/or External Keyboard Helper, but they all still involve popping up the Input Method Selector and manually choosing a different method. That's not really any different than the "Choose input method" notification I mentioned above, so it doesn't really help.

    So, does anyone know how to make the Hardware/Physical Keyboard setting default to On or at least keep the setting after I change it?
    09-25-2014 09:58 AM
  2. mgmchenry's Avatar
    Just tried the keyboard on my friend's HTC M8 and it works as expected (Hardware/Physical Keyboard setting On by default, on-screen keyboard hidden). So I guess it's not the keyboard. Most likely an LG problem, but I guess it could be a KitKat problem that HTC fixed in their firmware.

    I would appreciate it if anyone else with a KitKat phone and bluetooth keyboard would share their experience. Even if it doesn't solve my problem it might help narrow it down to LG and avoid vendor finger pointing when I try to escalate it.
    09-25-2014 03:44 PM

Similar Threads

  1. Replies: 1
    Last Post: 09-25-2014, 07:58 PM
  2. Changing the Lockscreen Timeout
    By CKR83 in forum Samsung Galaxy S5
    Replies: 5
    Last Post: 09-25-2014, 04:40 PM
  3. Why is there a large white blotch on my KoboArc??
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 09-25-2014, 02:59 PM
  4. Why can't I sign in to Google/Playstore?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-25-2014, 10:52 AM
  5. Replies: 2
    Last Post: 09-25-2014, 10:44 AM
LINK TO POST COPIED TO CLIPBOARD