1. Bob Gilman's Avatar
    Most say my device not compatible
    09-29-2014 06:20 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! The app page on Google Play specifically states that it requires Android 4.1 or higher. Sorry!
    09-29-2014 06:51 PM

Similar Threads

  1. Does anyone offer a service to ROM your phone for you?
    By Joe Mags in forum Samsung Galaxy Nexus
    Replies: 6
    Last Post: 01-14-2015, 09:18 AM
  2. How do I make GPS work on my phone?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-29-2014, 07:32 PM
LINK TO POST COPIED TO CLIPBOARD