1. AC Question's Avatar
    In all the earlier android phones i have used, if I keep my wifi ON, wifi used to connect automatically after searching when wifi is available. However, in case of LG G3, wifi connects when I manually connect and stays connected. However, in case I go to different room (out of range) and come back, it doesn't automatically connect. I have to switch on the screen, go to settings and have to go to wifi settings page to get it reconnected. Since I have wifi at office and at home, I was used to automatic internet connection all the time since I didn't have to remind phone to connect to wifi everytime.
    09-30-2014 06:57 AM
  2. srkmagnus's Avatar
    In all the earlier android phones i have used, if I keep my wifi ON, wifi used to connect automatically after searching when wifi is available. However, in case of LG G3, wifi connects when I manually connect and stays connected. However, in case I go to different room (out of range) and come back, it doesn't automatically connect. I have to switch on the screen, go to settings and have to go to wifi settings page to get it reconnected. Since I have wifi at office and at home, I was used to automatic internet connection all the time since I didn't have to remind phone to connect to wifi everytime.
    Go into system settings > Wi-Fi (wireless & networks). Click on the Wi-Fi network you are connected to then "forget". When you receive the prompt to connect to the network select it then "remember". Let us know if that works for you.
    09-30-2014 07:17 AM
  3. its4harish's Avatar
    Thank you for the reply. I disconnected and again reconnected like you suggested.
    There is a "forget" option. But there is no "remember" option.
    But it didn't work. Some additional observation is as below:
    1) Once it is connected, it stays connected even if screen is off. It disconnects only if out of range and do not automatically connect when back in the range.
    2) After switching on the screen, when I go to setting and then go to wifi, it automatically connects. What I mean is I don't have to manually select the available network to connect. From the wifi screen, it automatically connects.
    But the interesting thing is it doesn't automatically connect without going to wifi setting even if I am in range (i have checked for 2 hours).
    I think it might be some settings in phone to save battery by not connecting to wifi when not in use. But I don't want to enable that option since I will not know if I receive any messages through internet.
    10-01-2014 12:12 AM
  4. vashstrife's Avatar
    i have this issue as well. if i open my wifi menu, it will reconnect, but i should not have to do that. every other phone i've seen automatically reconnects after i re enter the router's range.
    10-09-2014 08:34 AM
  5. Rukbat's Avatar
    If you have scanning turned off (to save battery) it won't scan for networks, so it won't know when you come within rang of one.
    10-09-2014 11:07 AM
  6. its4harish's Avatar
    For G3, I went to service center due to same problem. They quickly understood. I'm not sure whether they changed hardware or sofware. Next day I received phone with everything fixed. No problems now.
    11-04-2014 09:39 PM

Similar Threads

  1. urgent please help,my phone is not turning on!!!
    By anox19 in forum Sony Xperia Z Ultra
    Replies: 2
    Last Post: 09-30-2014, 10:02 AM
  2. Replies: 1
    Last Post: 09-30-2014, 07:20 AM
  3. Replies: 1
    Last Post: 09-30-2014, 06:22 AM
  4. Replies: 0
    Last Post: 09-30-2014, 05:26 AM
LINK TO POST COPIED TO CLIPBOARD