1. mari_gm's Avatar
    Hi everyobe!!! I got the s5 recently and like it a lot but...i noticed that when i rotate it it usually takes around 4-6 seconds to catch up. I turned off the smart rotate feature and also reduced the animation scale to 0. The power save option is off and i don't know what else to do. Please help!!

    Posted via the Android Central App
    10-01-2014 05:21 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try wiping the cache partition: Reset: Samsung Galaxy S 5 | T-Mobile Support. If that doesn't help, try unmounting your SD card (in Settings>Storage), remove it, and reboot--a corrupt SD card can impact performance.
    mari_gm likes this.
    10-01-2014 06:35 PM
  3. mari_gm's Avatar
    I will try it out today. Will let u know. Tha.ks!!!!

    Posted via the Android Central App
    10-02-2014 08:13 AM
  4. mari_gm's Avatar
    Hiiii jist did what u suggested. Still no luck. should i just replace sd card with new one??

    Posted via the Android Central App
    10-06-2014 07:21 PM
  5. B. Diddy's Avatar
    Worth a try.
    10-06-2014 08:00 PM

Similar Threads

  1. Replies: 8
    Last Post: 09-26-2016, 12:34 PM
  2. How are people getting 5 hours of screen on time?
    By smalba in forum Samsung Galaxy S5
    Replies: 6
    Last Post: 11-06-2014, 07:34 PM
  3. picked up the Samsung Galaxy S5
    By Circa58 in forum Samsung Galaxy S5
    Replies: 4
    Last Post: 10-02-2014, 01:59 PM
  4. How do I turn off the speaker on the Samsung S5?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-01-2014, 04:59 PM
  5. How do I remove the weather widget on S5 Mini?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-01-2014, 04:49 PM
LINK TO POST COPIED TO CLIPBOARD