1. AC Question's Avatar
    I have a problem using My micro-SIM card on my new Sony Xperia T2 Ultra (Android 4.3)

    The problem is: when i insert the SIM card, the phone display a message that the SIM card has been inserted, and restarts... then after the restart, displays 'SIM card removed' and restarts!

    Notes:
    1-The SIM card works perfectly on other phones.

    2-The shop where my father bought the phone had pictures and some videos before i received it.

    Any solutions?
    10-05-2014 01:10 AM
  2. Nelwin Dugbei's Avatar
    I have a problem using My micro-SIM card on my new Sony Xperia T2 Ultra (Android 4.3)

    The problem is: when i insert the SIM card, the phone display a message that the SIM card has been inserted, and restarts... then after the restart, displays 'SIM card removed' and restarts!

    Notes:
    1-The SIM card works perfectly on other phones.

    2-The shop where my father bought the phone had pictures and some videos before i received it.

    Any solutions?
    07-12-2016 05:56 AM
  3. Nelwin Dugbei's Avatar
    I have a problem using My micro-SIM card on my new Sony Xperia T2 Ultra (Android 4.3)

    The problem is: when i insert the SIM card, the phone display a message that the SIM card has been inserted, and restarts... then after the restart, displays 'SIM card removed' and restarts!

    Notes:
    1-The SIM card works perfectly on other phones.

    2-The shop where my father bought the phone had pictures and some videos before i received it.

    Any solutions?
    Also being called Z1 by this website when I logged in
    07-12-2016 06:02 AM

Similar Threads

  1. Moto X 2014 review: Refinement
    By someguy01234 in forum Moto X (2014)
    Replies: 9
    Last Post: 10-09-2014, 09:32 AM
  2. Is it the new 128gb sd card or Kit Kat?
    By phone-a-holic in forum Samsung Galaxy S5
    Replies: 5
    Last Post: 10-06-2014, 02:29 PM
  3. Replies: 1
    Last Post: 10-04-2014, 10:23 PM
  4. Replies: 1
    Last Post: 10-04-2014, 08:19 PM
LINK TO POST COPIED TO CLIPBOARD