1. AC Question's Avatar
    Was working fine yesterday at noon but when I came home and plugged jack in it's acting as if it's not completely plugged in? Notification sounds and other noise from the phone actions (turning volume up/down) work fine,... they're from the speaker.

    -Headphone by itself works fine (on computer, other devices, etc)
    -Phone speakers work fine by itself as well.
    -Sounds as if it isn't plugged all the way in even though it is (it clicks on)
    -Checked inside of the jack with a small flashlight......can't see anything out of ordinary (no visible dirt, lint, etc I messed around inside with a toothpick)

    Phone (bought two years ago):

    "Samsung Galaxy S3 neo i9300i 16GB - Factory Unlocked International Version - Black"

    "Samsung Replacement EH64AVFWE 3.5mm Premium Stereo Headset - Non-Retail Packaging - White"

    On Amazon. Can't post links sorry.
    11-08-2014 03:29 PM
  2. Arlizz's Avatar
    Can anyone please answer???
    11-09-2014 11:09 PM
  3. Arlizz's Avatar
    bump
    11-09-2014 11:11 PM
  4. Rukbat's Avatar
    A few possibilities, all hardware-related. A bad connection on the jack, a weak spring on the jack (making an intermittent connection to the plug), a bad connection on the motherboard (least likely, since that would most likely affect the speaker too). In any case, the phone has to be opened up and checked.
    11-10-2014 11:29 AM

Similar Threads

  1. Replies: 1
    Last Post: 11-08-2014, 04:48 PM
  2. How do I retrieve contacts from an nonresponding Samsung?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 11-08-2014, 04:39 PM
  3. Replies: 1
    Last Post: 11-08-2014, 04:33 PM
  4. Replies: 1
    Last Post: 11-08-2014, 04:32 PM
  5. Do Samsung phones ship with protector over camera lens?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 11-08-2014, 04:29 PM
LINK TO POST COPIED TO CLIPBOARD