1. nstutzman20's Avatar
    When using Google Maps on my Verizon Samsung Galaxy S4 (Android 4.4.2), Google Maps does not engage the GPS, and therefore, my location is grossly inaccurate. I downloaded GPS Status app to help solve the problem with Google Maps not reporting my location accurately. When I start Google Maps, GPS Status does not show that Google Maps is using GPS. However, when I select a location, and then start Navigation, the app finds my location, and GPS Status reports that the app is using my GPS signal. When I stop navigating, Google Maps looses my location again. Other apps use GPS and locate my precise location perfectly. I have gone through and checked settings and it seems that everything is set to let Google Maps use the precise location, but I cannot seem to find the disconnect. I have uninstalled, installed, and updated Google Maps several times without any luck. I have also used a permission app to get to the "secret" permission menu, and the location is on for Maps. Last, I downloaded an old version of Google Maps, (Nima GL2 Edition) and that works to give me a precise location. Just not the most current, up to date, Google Maps. I am thinking it is a setting I am missing, I just don't know where to look. Any ideas?
    11-13-2014 10:33 PM
  2. Rukbat's Avatar
    I don't know how you're using GPS Status to tell whether Maps is "using" your GPS, but it's been evident for a while that Google "improved" Maps to not turn GPS on by itself. I use Tasker to turn it on if Maps is the foreground app. (Actually, since I use MyDirections to drive Maps, Tasker turns GPS on when MyDirections is the foreground app and doesn't turn it off for 5 seconds after another app comes to the foreground. If Maps is the new foreground app, GPS stays on. If it's the launcher GPS turns off.)
    11-13-2014 10:50 PM
  3. nstutzman20's Avatar
    Thanks for the reply. I did not explain very clearly my situation. I do not think I used the proper terminology. The GPS I was referring to, was not the option to turn location on, as done in the settings menu, but the actual task of seeking my location. I leave the location setting on at 'High Accuracy' at all times. I am not a power user, and therefore do not see the need to manipulate it. However, GPS Status has a setting to indicate when a program is seeking to find my locaiton. As an example, I have AutomateIt look for my location every 10 minutes to turn certain features on, depending on where I am at. So, every 10 minutes, an balloon and satellite icon appear, indicating that something is trying to find my location. The same icon appears in the upper left hand task bar corner when I start apps like MapQuest, or Google Navigation. However, when I start Google Maps, that icon does not appear and Google does not precisely locate my location, only to within a mile or so. I would assume that it means that Google Maps is not seeking my exact location. It is like there is a disconnect where Google Maps won't seek my location, yet everything else will. This leads me to believe that there is some permission setting or some hang up that doesn't allow Google Maps to find my location. I was curious if this was ever run into, or if I am missing something. Thanks again...
    11-23-2014 04:47 PM
  4. Rukbat's Avatar
    You probably have AutomateIt enable GPS. (That means that it turns the GPS receiver on.) Maps doesn't enable GPS, you have to do that manually or have AutomateIt do it for you when Maps runs. (I don't know if you can do that in AutomateIt, I use Tasker and you can have the fact that an app is running trigger a task, like enabling GPS.)
    11-23-2014 09:34 PM

Similar Threads

  1. New "Location" button vs Old "GPS" button
    By Catimba in forum Android 4.4 KitKat
    Replies: 7
    Last Post: 11-18-2014, 11:25 AM
  2. Google now?
    By elysm1 in forum Samsung Gear S
    Replies: 2
    Last Post: 11-14-2014, 06:11 AM
  3. Why is my battery draining?
    By brettbland in forum Ask a Question
    Replies: 2
    Last Post: 11-13-2014, 11:19 PM
  4. Why doesn't the Tap and Go on Android 5.0 setup menu work?
    By IOkeil in forum Android 5.0 Lollipop
    Replies: 0
    Last Post: 11-13-2014, 09:43 PM
  5. Why did my Note 3 delete my photos?
    By onjon81 in forum Samsung Galaxy Note 3
    Replies: 1
    Last Post: 11-13-2014, 05:08 PM
LINK TO POST COPIED TO CLIPBOARD