1. MikiSunshine's Avatar
    i know I turned my wifi off to save battery life. I'll be reading a book in Kindle, the Kindle locks up, and I notice my wifi is now on. It also seems like 30 apps have suddenly loaded and my memory and battery life and getting lower and lowers

    I turn off the wifi, close the apps I have no use for, and reload Kindle and the same thing happens after a short while. Rinse and repeat.

    Can someone help me figure out what program(s) are doing this and how to stop them?

    ETA: Using MetroPCS with an LG Spirit 4G and Android 4.0.4
    11-16-2014 01:27 PM
  2. Golfdriver97's Avatar
    Is there any way you can post screenshots of your battery stats please?
    11-16-2014 01:38 PM
  3. Sidney Henry's Avatar
    Some of the apps that you would have installed had asked for permission to access some of the features on your phone. One such feature is the WiFi. When you would have installed kindle it would have requested permission to access your Wifi among other things. By accepting and installing it has access to modify your phone settings.
    11-16-2014 01:40 PM
  4. Javier P's Avatar
    Check in settings - WiFi - advanced that "scanning always available" is off.
    11-16-2014 04:03 PM
  5. MikiSunshine's Avatar
    Not sure where to find the battery stats. But that's not the issue. How to stop my wifi from being turned on is my problem.
    11-16-2014 04:10 PM
  6. MikiSunshine's Avatar
    Under wifi, advanced, all I see I'd "keep wifi on during sleep", Mac address and IP address.
    11-16-2014 04:13 PM
  7. Javier P's Avatar
    Under wifi, advanced, all I see I'd "keep wifi on during sleep", Mac address and IP address.
    What phone and android version do you have?
    11-16-2014 04:26 PM
  8. MikiSunshine's Avatar
    I am so sorry. I thought I'd posted that. Duh. I'm using MetroPCS with an LG Spirit 4G with Android 4.0.4.
    11-16-2014 06:55 PM
  9. Javier P's Avatar
    Sorry, not familiar with that version. If there's not under WiFi settings it could be something similar in your carrier settings. Just a guess.
    11-16-2014 07:16 PM
  10. Golfdriver97's Avatar
    I am so sorry. I thought I'd posted that. Duh. I'm using MetroPCS with an LG Spirit 4G with Android 4.0.4.
    It may be Sprint's Connection "Optimizer". Go to Settings>Wireless and Networks>More...>Mobile Networks>Connection Optimiizer. Turn it off.
    11-16-2014 07:32 PM
  11. MikiSunshine's Avatar
    It may be Sprint's Connection "Optimizer". Go to Settings>Wireless and Networks>More...>Mobile Networks>Connection Optimiizer. Turn it off.
    Metropcs may now be Sprint but as for my phone, it's still MetroPCS only. I don't have access to. Connection optimizer.
    11-17-2014 06:15 PM
  12. MikiSunshine's Avatar
    Some of the apps that you would have installed had asked for permission to access some of the features on your phone. One such feature is the WiFi. When you would have installed kindle it would have requested permission to access your Wifi among other things. By accepting and installing it has access to modify your phone settings.
    Just saw this. I know about granting permissions to apps but Kindle doesn't turn the WiFi on or off. Just accesses it when available. Any way to find out what other app or apps may actually have permission to turn it on?
    11-18-2014 02:36 PM

Similar Threads

  1. What Phone are You Coming From?
    By cgooge14 in forum Samsung Galaxy Note Edge
    Replies: 16
    Last Post: 11-22-2014, 06:36 PM
  2. is this a bug in android 5? (battery usage)
    By Hamzeh_Awadallah in forum LG G3
    Replies: 19
    Last Post: 11-22-2014, 12:15 PM
  3. Replies: 2
    Last Post: 11-17-2014, 01:39 AM
  4. Replies: 2
    Last Post: 11-16-2014, 04:01 PM
  5. Still more freakeeze on my S4
    By suthern_man in forum Ask a Question
    Replies: 1
    Last Post: 11-16-2014, 02:21 PM
LINK TO POST COPIED TO CLIPBOARD