1. Emmanuel Hernandez4's Avatar
    Well i have the galaxy mega and i have internet and all connect but when I try to make or even sign in to my old play store account it will say " Cant establish a reliable connection to the server. This could be a temporary problem or your android device may not be provisioned for data services. if it continues call customer care. Be aware i have a galaxy mega ! help guys
    12-04-2014 03:16 PM
  2. anon8380037's Avatar
    Hello.
    So when you say your old account, have you just switched to the Mega. It would need to be on your Play Store device list, usually by logging in to Google when you first set up.

    From my SM-N9005 Note 3 on Tapatalk
    12-04-2014 03:31 PM
  3. itheleoi's Avatar
    You could try to sign in with that account on some other google app such as gmail, or try adding the google account in settings. Btw, is this the first time you are signing in to the play store on your the galaxy mega.
    anon8380037 likes this.
    12-04-2014 03:36 PM
  4. Emmanuel Hernandez4's Avatar
    it still says that Cant establish a reliable connection to the server. This could be a temporary problem or your android device may not be provisioned for data services. if it continues call customer care.
    12-04-2014 03:38 PM
  5. Emmanuel Hernandez4's Avatar
    12-04-2014 03:38 PM
  6. Rukbat's Avatar
    It could just be a server problem. Try signing into the same account that's in the Mega (in Accounts/Google) with a web browser - you can use GMail, Contacts or any other Google service. Then go to Google Play on the browser and install whatever you want. (Choose your Mega when you get the popup.)
    anon8380037 likes this.
    12-04-2014 03:48 PM
  7. Emmanuel Hernandez4's Avatar
    when i log into it it says You dont have any devices. i got this far .
    12-04-2014 04:15 PM

Similar Threads

  1. Gear S only charges to 96%
    By thegame161 in forum Samsung Gear S
    Replies: 8
    Last Post: 12-28-2014, 09:55 AM
  2. Replies: 2
    Last Post: 12-05-2014, 08:15 PM
  3. Replies: 6
    Last Post: 12-05-2014, 05:54 AM
  4. Why won't my Galaxy Tab 3 play videos?
    By FrankGarner in forum General Help and How To
    Replies: 1
    Last Post: 12-04-2014, 03:49 PM
LINK TO POST COPIED TO CLIPBOARD