1. PaLy Duh's Avatar
    It shows "connected" but I am unable to access any webpage.

    I tried: Rebooting the router. Removing the sim card. Hard reboot on the phone. Guest network on the router. Updating the phone.

    The phone is seen as a device on the router and I am able to connect my laptop without any problem.

    Please help!
    12-12-2014 02:39 PM
  2. belodion's Avatar
    Welcome to the forums.☺

    Is this a new device? Can you connect normally via mobile data?

    Posted via the Android Central App
    12-12-2014 02:52 PM
  3. IslaG's Avatar
    I have the same problem. I started using my phone in mid Sept but there has always been an exclamation mark next to the wifi connection. It works fine with the mobile data switch on.
    11-08-2015 11:29 AM
  4. belodion's Avatar
    I have the same problem. I started using my phone in mid Sept but there has always been an exclamation mark next to the wifi connection. It works fine with the mobile data switch on.
    Welcome to the forums.

    Do other devices connect to the internet okay on your home wifi?
    Similarly, does your device connect to the internet using other wifi hotspots?
    It may be worth contacting your ISP over the problem.
    Also, this guide may help:
    [GUIDE] Troubleshooting Wi-Fi Connection Problems
    11-08-2015 01:31 PM

Similar Threads

  1. Which new phone should I get?
    By djturnz in forum General Help and How To
    Replies: 6
    Last Post: 12-14-2014, 07:29 PM
  2. Verizon Motorola Droid Turbo Re-directing pop-up to play store?
    By SevenDBO in forum Motorola Droid Turbo
    Replies: 5
    Last Post: 12-14-2014, 08:50 AM
  3. Replies: 2
    Last Post: 12-12-2014, 06:07 PM
  4. Can I use an iMac to drag and drop music to Android phone?
    By joebloggs13 in forum General Help and How To
    Replies: 2
    Last Post: 12-12-2014, 03:07 PM
  5. Replies: 0
    Last Post: 12-12-2014, 02:06 PM
LINK TO POST COPIED TO CLIPBOARD