1. BMXdude13's Avatar
    So ive got a note4 on Verizon,

    Love the phone, Everything is snappy and works as intended.
    The problem i'm experiencning is this,

    Whenever i go to load a web page (Regardless of wifi or data) there is a few seconds delay after i hit enter. What i mean by that is its like its loading the webpage, just very slowly. or trying to establish the connection. Once its loaded everything is fine. It's just the initial load takes forever, regardless of weather or not i've been to the site before.

    Same goes for apps like Instagram,tumblr,facebook,and snapchat. It'll take 4-5 seconds to refresh the page, then another 2-3 to load the images.

    The time it takes to connect across everything is about 3-5 second consistantly.

    Anyone know what the issue could be? or is this typical and just seems like it takes forever cause the phone is so fast?

    I have Fios, at work/home as well as solid 4g lte coverage in my area.

    TL;DR Takes a few second to load webpages and apps even on fast internet.
    12-23-2014 02:38 PM
  2. srkmagnus's Avatar
    So ive got a note4 on Verizon,

    Love the phone, Everything is snappy and works as intended.
    The problem i'm experiencning is this,

    Whenever i go to load a web page (Regardless of wifi or data) there is a few seconds delay after i hit enter. What i mean by that is its like its loading the webpage, just very slowly. or trying to establish the connection. Once its loaded everything is fine. It's just the initial load takes forever, regardless of weather or not i've been to the site before.

    Same goes for apps like Instagram,tumblr,facebook,and snapchat. It'll take 4-5 seconds to refresh the page, then another 2-3 to load the images.

    The time it takes to connect across everything is about 3-5 second consistantly.

    Anyone know what the issue could be? or is this typical and just seems like it takes forever cause the phone is so fast?

    I have Fios, at work/home as well as solid 4g lte coverage in my area.

    TL;DR Takes a few second to load webpages and apps even on fast internet.
    Welcome to the forums!

    Go into recovery and clear the cache. Do this by powering off - hold the home button+volume up (it might be down, but hold up first)+power on. Use the volume button to select cache then power to accept. Reboot and see if that helps.

    Good luck!
    12-23-2014 07:58 PM

Similar Threads

  1. Replies: 1
    Last Post: 12-24-2014, 04:50 AM
  2. Note 4 Delay/Lag
    By BaldwiJ7 in forum Samsung Galaxy Note 4
    Replies: 2
    Last Post: 12-23-2014, 01:52 PM
  3. How do I get my screen to rotate to use the Allshare cast dongle?
    By Shannonelaine1120 in forum Ask a Question
    Replies: 0
    Last Post: 12-23-2014, 01:19 PM
  4. Video review of 4 cases (with a kinda drop test)
    By magichoward in forum Samsung Galaxy Note 4
    Replies: 0
    Last Post: 12-23-2014, 11:53 AM
LINK TO POST COPIED TO CLIPBOARD