1. Ruan Arendt's Avatar
    Hello everyone.
    Yesterday I purchased a brand new Sony Xperia M2. As I tried to take a picture with front facing camera,it had an error message saying 'camera not available'. Any tips or anything I can do to fix this problem.
    Thanks:-).

    Posted via the Android Central App
    01-16-2015 09:47 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Does that persist after a reboot? Does the rear-facing camera work normally?

    Since the phone is so new, I'd just bring it back to the store and ask for an exchange.
    Ruan Arendt likes this.
    01-16-2015 10:18 AM
  3. Ruan Arendt's Avatar
    The rear camera works perfectly. And this issue started before any reboot or power off. I'll take it back to my carrier and ask for a replacement since its faulty and under warranty. Thanks for your reply! :-)

    Posted via the Android Central App
    01-16-2015 05:11 PM
  4. Ruan Arendt's Avatar
    And this happens

    Posted via the Android Central App
    Attached Thumbnails Sony Xperia M2 Aqua front camera not working-screenshot_2015-01-17-01-13-41.jpg  
    01-16-2015 05:14 PM
  5. B. Diddy's Avatar
    That kind of thing can happen sometimes if you've been using the flashlight function. There have been various bug reports for different devices (mostly running Lollipop) where use of the flashlight toggle tends to interfere with the Camera function. Since the LED flash (which is used for the flashlight) and the camera are connected, it's not that surprising that this kind of glitch exists.
    01-16-2015 06:15 PM
  6. Ruan Arendt's Avatar
    Okay I see. Good to know. So there is nothing I can do to fix this myself? Just take it back?

    Posted via the Android Central App
    01-17-2015 12:59 AM
  7. B. Diddy's Avatar
    I'm not aware of a fix, but I'm certainly not an expert in the field ...
    01-17-2015 01:51 AM

Similar Threads

  1. Replies: 11
    Last Post: 02-08-2017, 10:57 PM
  2. Not impressed with the display
    By MikeLip in forum Motorola Droid Turbo
    Replies: 10
    Last Post: 01-18-2015, 04:13 PM
  3. Replies: 1
    Last Post: 01-16-2015, 10:25 AM
  4. I have no phone signal, yet data works, how is this possible?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-16-2015, 10:05 AM
  5. Replies: 1
    Last Post: 01-16-2015, 09:22 AM
LINK TO POST COPIED TO CLIPBOARD