1. AC Question's Avatar
    Okay so I got a new s3 a few days ago. Before yesterday it was charging just fine. But now when I plug in the charger (the s3 will recognize the charger) I see the charging symbol and of two things happens...
    1. On highest brightness level the phone will discharge slowly even when plugged in.

    2. On lowest brightness my phone will charge VERY slowly when plugged in.

    Someone please tell me whats causing the issue.
    01-17-2015 07:50 AM
  2. belodion's Avatar
    There is a fault....return the device.

    Posted via the Android Central App
    01-17-2015 09:01 AM
  3. Golfdriver97's Avatar
    Returning the device to the carrier store, like belodion said, is an option. You can also test to see if the wall unit/cable is at fault by using a different set up. The battery may be going bad as well.

    To test the battery, take it out and on a flat surface, try to spin it. If it does, the battery is bulged and needs to be replaced.
    01-17-2015 10:17 AM

Similar Threads

  1. How to root ADMET 7040D android no Pc?Please help me.
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 11-18-2015, 10:47 AM
  2. Why won't my Galaxy Note 2 charge?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-18-2015, 02:01 AM
  3. Replies: 1
    Last Post: 01-17-2015, 07:42 AM
  4. Replies: 0
    Last Post: 01-17-2015, 07:38 AM
  5. S3 Touch Screen Buttons Dont Light Up??
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-17-2015, 06:50 AM
LINK TO POST COPIED TO CLIPBOARD