1. AC Question's Avatar
    I live in Arizona where we do not observe daylight savings time. We have our own time zone setting available (Arizona GMT-7:00). Every year, for the winter half of the year, the calendar on my Galaxy S4 displays appointments that are synced from my Outlook account at the wrong time. Everyone else I've spoken to with a Galaxy phone indicates they also experience the same problem. The issue seems to stem from the fact that with Auto Time Zone selected, the phone chooses the Mountain (MST) time zone rather than Arizona. As a result, it pushes all of my appointments forward an hour apparently thinking that we were on MDT during the summer. If I select an individual appointment in the calendar on the phone and reset its time zone to Arizona, it moves to the correct time. How can I get my phone to recognize that it should be selecting the Arizona time zone for the entire phone? Is this a Verizon issue? A Samsung issue? I don't understand! I really like to keep Auto Time Zone on because it keeps my calendar accurate when I travel. Any ideas would be most welcomed by me along with half the people in my office.
    01-19-2015 12:19 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! That's frustrating. On my Nexus 5, when I look through the available time zones, I don't see an Arizona Standard Time option, but I do see two Mountain Standard Time options (both of which say GMT-7:00). I wonder if one of those is supposed to be for Arizona, but someone messed up and didn't call it Arizona Standard Time? How many Mountain Standard Time options do you have in your list?
    01-22-2015 12:32 AM
  3. Takan's Avatar
    OK, it's now been a year since you posted this problem, and I have had this same problem each year too. This time, I'm trying to do something about it because I almost missed a meeting because of this issue. Did you find any solution? If not, here's a bump in the thread to see if we can find one.

    My details: T-mobile, Galaxy S4, Android 4.4.4. I can't even manually turn off automatic update of time & time zone--it automatically turns it all back on after reboot and then automatically selects the "hidden" Mountain Standard Time: GMT-7:00 setting, even though right now MST is actually GMT-6.

    Anyone? Please help.
    03-14-2017 01:34 PM

Similar Threads

  1. Replies: 2
    Last Post: 01-19-2015, 03:13 PM
  2. Why is the smiley face missing on my Submenu for emogis?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-19-2015, 11:52 AM
  3. Replies: 1
    Last Post: 01-19-2015, 11:23 AM
  4. Replies: 0
    Last Post: 01-19-2015, 11:13 AM
  5. Why cant I enter digits in call?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-19-2015, 10:52 AM
LINK TO POST COPIED TO CLIPBOARD