1. AC Question's Avatar
    My samsung galaxy tab S 10.5 is not compatable with any version of the whatsapp app. Is there anything i can do to download it to my tablet? Android version 4.4 kitkat.
    01-29-2015 11:41 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! If it's not compatible through Google Play, then trying to install it some other way may not work, or it might cause instability. You could try other app sources like Amazon Appstore, SlideMe, or GetJar.
    01-30-2015 02:49 PM
  3. mbanu's Avatar
    My samsung galaxy tab S 10.5 is not compatable with any version of the whatsapp app. Is there anything i can do to download it to my tablet? Android version 4.4 kitkat.
    yes, dont think its compatible
    01-30-2015 04:10 PM

Similar Threads

  1. Replies: 2
    Last Post: 03-05-2016, 12:51 AM
  2. Replies: 1
    Last Post: 01-30-2015, 02:53 PM
  3. How do i use my emojis in my contacts after the 4.4.4 update? :(
    By ChowBella388 in forum General Help and How To
    Replies: 0
    Last Post: 01-29-2015, 11:32 PM
  4. Replies: 1
    Last Post: 01-29-2015, 11:32 PM
LINK TO POST COPIED TO CLIPBOARD