1. AC Question's Avatar
    My phone's icon indicator for mobile data won't show up even though it's turned on that's why i couldn't use my mobile data for days. I tried turning it off/on but it didn't work. Please help meeee
    03-23-2015 05:25 AM
  2. belodion's Avatar
    Try switching Airplane Mode on and off, and Mobile Data off and on....in other words, repeatedly toggling those, to try to trigger Mobile Data to connect. Power Off followed by Restart may also be helpful.

    Posted via the Android Central App
    03-23-2015 07:02 AM
  3. Robert Junio's Avatar
    We have the same problem by the way did you fix your phone mine is still not working
    05-26-2015 05:07 AM
  4. Conrad De Leon's Avatar
    got the same problem here.pls help us out.just got phine for less than a month and this happens
    07-12-2015 08:25 AM
  5. EmmiZxiz's Avatar
    I am also facing this problem any one plz tell me the way how to solve it even these steps not working
    08-10-2015 03:47 AM
  6. techsupportberry's Avatar
    Just go to Settings>More Networks> Mobile Networks>Access Point Names (APNs)>Tap the 3-dot like colon on the upper right side>Select "Reset to Default" Hope it helps.
    08-12-2015 10:15 PM
  7. nofear235's Avatar
    Go to Setting ................ then More Networks .... mobile networks
    there u will find ur both sim cards what you have to do is only change the network mode from auto WCDMA/GSM to WCDMA only
    (change sim setting on that you are using mobile data Example Sim 1 )
    now you are done
    I also had faced that problem i tried everything restart ,shutdown, shuffle again and again it worked for some time then again same problem i restored my phone even then it showing sim card manager again and again

    so try these simple steps which i mention up hope it will fine

    thanks ......
    10-13-2015 04:51 AM
  8. abhay anand's Avatar
    Thanks, given solution to reset APN setting worked!
    11-05-2015 07:19 PM
  9. rajendra phani's Avatar
    thanks the apn settings solution cleared my problem
    12-27-2015 09:22 PM
  10. Flutter01's Avatar
    I found a link that fixed my mobile data issue. Go to Data usage>make sure there is no data limit set (I was able to toggle (mobile data to on from this screen) then I went into Mobile networks and then I was able to switch it to the on position... easy peasy.
    03-29-2016 08:52 PM
  11. Roma2Pt0's Avatar
    I just had the same issue. I turned my mobile data on and off and then turned my phone on and off. It is working now, I'm posting this from mobile data.
    04-22-2016 05:00 PM
  12. Aspsp47's Avatar
    I'm buy mobile from nepal and it work fine . But when i came in japan and insort japan softbank sim it only ok for voice calling and messaging. I want use mobile data and open data but data active logo not appear and data also not active. Please help me to solve problem.
    06-23-2016 09:40 AM

Similar Threads

  1. Replies: 1
    Last Post: 03-23-2015, 05:32 PM
  2. Can I please get some help getting my data to work?
    By AC Question in forum Samsung Galaxy S3
    Replies: 1
    Last Post: 03-23-2015, 05:22 PM
  3. Galaxy S3: Why won't my data work?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-23-2015, 10:17 AM
LINK TO POST COPIED TO CLIPBOARD