1. AC Question's Avatar
    When I go to Google play for a newer app (7 rewards, local weather app) it states no device compatible. Will the ics make my Pantech Burst compatible?
    03-27-2015 09:29 PM
  2. Rukbat's Avatar
    It depends on the app. Some need 4.0 minimum, some need 4.1 or 4.3 or 5.x. Some will work only on certain hardware.

    It probably wouldn't hurt to update the phone, since it was made to be updatable to ICS, but don't count on too many currently available apps working with it - it's over 3 years old which, in Android terms, is about 4 generations old (like a 100 year old person).
    03-27-2015 10:30 PM

Similar Threads

  1. Is this a good phone for a 12 year old girl?
    By OceanView in forum Moto E (2015)
    Replies: 13
    Last Post: 07-18-2015, 02:41 PM
  2. Replies: 2
    Last Post: 04-06-2015, 09:46 AM
  3. Replies: 1
    Last Post: 03-28-2015, 02:00 AM
  4. How do i disable Moto X 2nd gen voice?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-27-2015, 09:04 PM
LINK TO POST COPIED TO CLIPBOARD