1. AC Question's Avatar
    I recently received the Android 5.0.2 update for my AT&T HTC One M7. Since then, the phone is exhibiting weird Wi-Fi behavior. To elaborate:

    The Wi-Fi cannot be turned OFF and it remains ON throughout, also during sleep mode, even though I have selected 'Never' for the 'Keep Wi-Fi ON during sleep' option under the Advanced Wi-Fi settings menu. I have also tried to switch OFF the Wi-Fi manually, but am unsuccessful. Here are the steps I've tried hoping to fix the issue:

    1) Did the factory reset (twice)
    2) Cleared the Cache partition.
    3) Cleared Data/cache of the Phone app (per HTC support).

    None of the above fixed the issue. I have to restart the phone every time to switch OFF the Wi-Fi, which is annoying! After restart, it works ok for an hour or so and then the problem reappears. Is this a bug in the 5.0.2 release? It was working well in OS 4.4.2.

    Please let me know if there's a solution to this issue or if HTC recognizes this and is working for a solution.

    Thanks
    Arjun
    04-08-2015 10:13 PM
  2. belodion's Avatar
    Welcome to Android Central.

    Try Advanced WiFi settings again, and see whether you have a Smart Network setting or something similar. If so, turn it off.
    Otherwise, have you tried Safe Mode? A third-party app may be causing trouble.

    Posted via the Android Central App
    04-09-2015 04:52 AM
  3. Kevin Shaw's Avatar
    I had the same issue this morning: hidden home network not available, failed to save when added, couldn't turn wifi off. A reboot solved the problem for now: Hidden network reappeared in network list, connected OK, wifi cycles on and off on demand.

    We'll need to keep an eye on this, I suppose.
    04-09-2015 06:34 AM
  4. Arjun Shekar's Avatar
    Thanks belodion. I still have not tried the Safe mode. Will try it now and let you know if an app is causing this issue.

    On a side note, the WiFi was turning OFF and ON on demand when I had 4.4.2. Also, in the current state with 5.0.2, the WiFi works fine for a few minutes after a restart but after a while this problem reappears again.

    I tried reaching HTC support again, but looks like they are not aware of this software bug (if it is one). Anyways, please let me know if you can think of other possible debug solution(s).

    Regards,
    Arjun
    04-09-2015 07:45 AM
  5. Arjun Shekar's Avatar
    Hello Kevin,
    I do not have any issues with the unavailable hidden network and network save problems, not yet at least!
    Regarding the WiFi turning OFF issue, Yes, it resolves temporarily after a restart and we would be able to toggle the WiFi ON and OFF on demand. But, this issue appears again after sometime (about say 1-2 hrs after)! Not quite sure if the device is an issue (which I don't think so because it was working fine with 4.4.2) or the software. Anyways, please keep me posted regarding your observation and let me know if the issue is resolved for you. Thanks!

    Regards,
    Arjun
    04-09-2015 07:55 AM
  6. Sandwiched's Avatar
    I'm having the same issue, or one very similar. My HTC One (m7) recently got Lollipop, and I've had this issue ever since.

    WiFi will work normally for a few hours, and then at some point I'll wake my phone up and notice that it's not connecting to WiFi. The WiFi toggle in the notification shade shows the WiFi to be on, and it even detects my home and neighbors' networks properly. However, when I tell it to connect (which it should do automatically), it asks for the password (which it should have stored), and then once I type it in and tap to continue, it instantly displays an error message "Failed to connect to network" - and I mean INSTANTLY. It definitely doesn't have enough time to even attempt negotiation of a connection.

    Once in this state, I can't turn WiFi off, nor can I get it to connect via any methods other than restarting the entire phone.
    04-15-2015 08:33 PM
  7. Cirax's Avatar
    I am also having this issue I've tried changing the baseband installing Cyanogen. Revolution HD. Viper One and nothing the problem still persists.
    04-19-2015 09:44 PM
  8. I-Way Vagabond's Avatar
    Hello,

    I've been experiencing the exact same problems that the OP described. I've booted into recovery and cleared the cache partition. I even did a factory reset. Neither worked to solve the problem.

    As ready mentioned, turning the phone off and on does resolve the problem temporarily.

    Like others have mentioned, my WiFi worked fine before I updated to Lollipop.

    Edit: I just spoke with HTC's Tech Support. They recommended that I manually re-install the Lollipop update using the RUU file on their Web site.

    Unfortunately, I do not have enough posts to provide a link. But the manual update is available on HTC's Web site.
    04-20-2015 09:00 AM
  9. Arjun Shekar's Avatar
    I was able to find an interim solution (trial and error) for the 'Unable to switch OFF Wi-Fi' issue, but this does not solve the problem though. The only advantage is that the phone need not be restarted when you're trying to switch OFF Wi-Fi.

    Goto the 'Advanced' settings menu under Wi-Fi and check and uncheck the 'Scanning always available' option (Yes, you need to toggle). Somehow, this toggling seems to reset the wireless adapter when this issue is prevalent. After this, I was able to switch OFF and ON the Wi-Fi on demand, only for a short time after which the problem appeared again. Note that this is the case only when you're unable to switch OFF Wi-Fi.
    04-21-2015 04:08 PM
  10. Enrique Guerra's Avatar
    escribo desde Lima Perú... tengo un MOTO G... tengo problemas con WIFI.... similar a los comentados lineas arriba...
    espero una pronta solución..!!!!!
    04-21-2015 04:47 PM
  11. Enrique Guerra's Avatar
    Despues de actualizar a lollipop 5.0.2 no me funcionaban los datos moviles ,lo solucione configurando la APN manualmente con los datos obtenidos de la pagina del operador.
    HASTA AHORA TODO PERFECTO.
    04-21-2015 05:03 PM
  12. Sandwiched's Avatar
    My issue appears to be gone now, and I think I know how. Each time the WiFi would get "stuck" and I'd restart the phone, it would display some sort of "Android is finishing upgrading to Lollipop" message during boot. It was as if restarting while the WiFi was "stuck" triggered this message or something.

    In any case, one day I decided to restart again, right after the phone finished restarting, and before the WiFi could get "stuck" again. This time, there was no "completing upgrade" message, and the WiFi has behaved properly ever since. YMMV...
    04-22-2015 04:49 AM
  13. kkeki's Avatar
    Hi guys
    Did anyone find a solution? I'm also having the same problem, I have to restart the HTC to turn wi-fi off. Help!

    Thanks!
    04-27-2015 03:49 PM
  14. JACrazy's Avatar
    I was able to find an interim solution (trial and error) for the 'Unable to switch OFF Wi-Fi' issue, but this does not solve the problem though. The only advantage is that the phone need not be restarted when you're trying to switch OFF Wi-Fi.

    Goto the 'Advanced' settings menu under Wi-Fi and check and uncheck the 'Scanning always available' option (Yes, you need to toggle). Somehow, this toggling seems to reset the wireless adapter when this issue is prevalent. After this, I was able to switch OFF and ON the Wi-Fi on demand, only for a short time after which the problem appeared again. Note that this is the case only when you're unable to switch OFF Wi-Fi.
    Thanks, this temporary solutions works. Doesnt solve the problem but it at least makes it so that I don't need to restart my phone.
    06-01-2015 12:50 AM
  15. alchilleus09's Avatar
    Update was done on my HTC One . Messages lags about 30-40sec before opening, message not sent (unfortunately, message not sent ) message all the time, 50% battery time left, it dies. Lots of lag! Really frustrated with new updates. Cannot send text or mail. Any help or fixes available?
    06-09-2015 02:43 PM
  16. SatishReddy's Avatar
    I have the same issue with my HTC ONE
    07-02-2015 05:25 AM
  17. c willy's Avatar
    Yep, me too. WIFI won't turn off and stay off. Constantly interrupts me when I am looking up something and am in range of a WIFI signal. HTC support had me clear my cache. Until then, I could go to the advanced setting and toggle the "always scanning" on and off. That would leave it off for about five minutes. Wiping the cache stopped that workaround from working. I've also working in safe mode, but it still wants to turn on. Never a problem until the Lollipop update. Can't find an advanced setting to stop it. Maybe its an app that is interferring, but since it only started after Lollipop, I tend to blame the update. Haven't tried to reinstall the update manually but will probably try that.

    Anyone else find a fix? This is super irritating.
    08-05-2015 12:22 PM

Similar Threads

  1. Replies: 15
    Last Post: 03-25-2017, 10:21 PM
  2. No Multi-user Support on AT&T?
    By James Dement in forum Samsung Galaxy S6 edge
    Replies: 1
    Last Post: 04-20-2015, 05:26 PM
  3. MKBHD HTC One M9 Review
    By festinator in forum HTC One M9
    Replies: 16
    Last Post: 04-11-2015, 12:43 PM
  4. Sprint/Credo Galaxy S5 Lollipop Updated Today!
    By Shannon1981 in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 04-09-2015, 08:33 PM
  5. Lollipop - stock vs third party apps
    By logik brooklyn in forum Samsung Galaxy Note 4
    Replies: 1
    Last Post: 04-08-2015, 09:51 PM
LINK TO POST COPIED TO CLIPBOARD