1. FantasticFangirl's Avatar
    Hello to all! I have owned a Samsung Galaxy S4 for 6 months now, and for the past 3 months, my 4G LTE has not been working at all. For example, if I go on the internet, it will show a "Content Restricted" notification, but if I am connected to any Wi-Fi network, it never shows this. Another example, if I go on Pinterest (one of my favorite apps) it does show any images at all. It is very odd because it used to work just fine and now it doesn't work at all. My current carrier is T-Mobile (if that matters). Here is what I have tried:

    -Turning airplane mode on and off
    -Checking and messing with the "Mobile Networks" settings
    -Checking my SIM card

    If there is anyone who has experienced the same thing and found a solution or someone who knows how to fix this, help would be GREAT. Thanks!
    04-12-2015 04:20 PM
  2. belodion's Avatar
    Welcome to Android Central.

    So, if I understand you right, what you're saying is that you're unable to use Mobile Data, but Wi-Fi is working okay?

    Have you spoken to T-Mobile about this?

    Posted via the Android Central App
    04-12-2015 04:33 PM
  3. Golfdriver97's Avatar
    Welcome to Android Central. Have you tried a reboot?
    04-12-2015 04:38 PM

Similar Threads

  1. My Galaxy S3 Mini screen goes blank when screen locks. Help?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-13-2015, 01:07 AM
  2. NEED HELP lost Private files
    By bgbagz in forum Samsung Galaxy Note 4
    Replies: 2
    Last Post: 04-12-2015, 10:04 PM
  3. Replies: 1
    Last Post: 04-12-2015, 09:45 PM
  4. Why is my mobile network now not working?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-12-2015, 09:39 PM
LINK TO POST COPIED TO CLIPBOARD