1. Ryu Camua's Avatar
    Hello, I'm new to android central and I need help on how to fix this issue I'm having with my S5. I had this for a year as a 2 year contract phone and after 10 months I damaged the AMOLED display and I hadn't used it for 2 months. I had to switch the sim card to the lumia 520 4G GoPhone to make calls and do my everyday tasks on my phone. After getting my phone's screen repaired for 2 months I switched the sim card to the S5 however I'm only getting 4G signals, is this because my sim locked to the GoPhone's signal? I never accessed the charging port of my s5, just replaced the display itself. By the way I had to put the APN settings on custom (that means the 4G LTE APN settings for AT&T) instead of default APN since I don't get any 4g reception on it, just signal bars appearing and calls/texts only, no data. My 4g signals in my S5 work just as fine as Lumia 520 however I just don't receive any LTE. Any solutions to this issue? I'm pretty sure that it's my sim card not the cellular antenna of my phone.

    Posted via the Android Central App
    04-26-2015 04:19 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Have you asked AT&T for any assistance? Can you delete that APN setting, then reenter it again?
    04-27-2015 01:51 AM

Similar Threads

  1. Galaxy S5 temp questions!
    By power4rmor in forum Samsung Galaxy S5
    Replies: 4
    Last Post: 05-01-2015, 09:44 AM
  2. How can I fix my Samsung Tab Galaxy S 8.4?
    By AC Question in forum Samsung Galaxy Tab S 8.4
    Replies: 1
    Last Post: 04-27-2015, 03:28 AM
  3. I have a Samsung Galaxy 4 Note, why am I unable to read my old emails?
    By AC Question in forum Samsung Galaxy Note 4
    Replies: 1
    Last Post: 04-27-2015, 03:22 AM
  4. app cache folder on s5
    By greatdj123 in forum Ask a Question
    Replies: 1
    Last Post: 04-27-2015, 03:14 AM
  5. Replies: 1
    Last Post: 04-27-2015, 03:07 AM
LINK TO POST COPIED TO CLIPBOARD