1. AC Question's Avatar
    Hey everyone, ever since I updated my phone if I ever connect to a wifi network, when I disconnect/turn my WiFi out mobile data won't connect. I simply have no mobile data icon and I can't browse the Web? The only way to fix it is to pull the battery out of my phone while it's on, tried restarting it properly and it didn't fix the problem. And then as soon as I find more WiFi this happens again. Any suggestions? Galaxy S5?
    05-01-2015 10:19 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Go to Settings>Wi-fi​, tap Menu>Advanced, and turn off Smart Network Switch (if present).
  3. B. Diddy's Avatar
    Welcome to Android Central! Go to Settings>Wi-fi​, tap Menu>Advanced, and turn off Smart Network Switch (if present).
    05-01-2015 10:47 AM
  4. andrewscool101's Avatar
    Welcome to Android Central! Go to Settings>Wi-fi​, tap Menu>Advanced, and turn off Smart Network Switch (if present).
    Hi, it's me OP. It's already off.
    05-01-2015 12:09 PM
  5. B. Diddy's Avatar
    What other Advanced Wi-fi settings do you see there?
    05-01-2015 01:23 PM
  6. andrewscool101's Avatar
    What other Advanced Wi-fi settings do you see there?
    Network notification and passport are greyed out unchangeable and ticked. Sort by is signal strength. Keep WiFi on during sleep is only when plugged in. Always allow scanning is ticked. Install certificates and WiFi timer is also there.
    05-02-2015 02:03 AM
  7. B. Diddy's Avatar
    What happens if you turn off Always Allow Scanning? Maybe the fact that the phone is allowed to turn on wi-fi on its own is messing up the cell radio's ability to connect to a signal.
    05-02-2015 02:05 AM
  8. andrewscool101's Avatar
    What happens if you turn off Always Allow Scanning? Maybe the fact that the phone is allowed to turn on wi-fi on its own is messing up the cell radio's ability to connect to a signal.
    I had a weird result where it wouldn't work as usual, I locked my phone for about 2 mins while I drove to where I needed to be, checked my phone again and mobile data was back. I'll try and replicate the results.
    05-02-2015 05:36 AM
  9. andrewscool101's Avatar
    Wiping the cache partition in recovery mode seems to have resolved the issue.
    B. Diddy likes this.
    05-06-2015 01:22 PM

Similar Threads

  1. Why isn't my Galaxy S2 sensor working?
    By AC Question in forum Samsung Galaxy S2
    Replies: 1
    Last Post: 05-01-2015, 10:54 AM
  2. Rooting Galaxy Ace Style G357FZ?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 05-01-2015, 10:16 AM
  3. My Galaxy S3 stopped connecting to Google.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-01-2015, 09:55 AM
  4. Samsung Galaxy S2 (SGH-I777) cannot boot into Recovery mode.
    By Kiran Johny in forum AT&T Galaxy S II
    Replies: 0
    Last Post: 05-01-2015, 08:56 AM
LINK TO POST COPIED TO CLIPBOARD