1. AC Question's Avatar
    i try to update my mobile it shows your are already modified but my mobile android version is 4.1.2
    when i downlod games like immortals it doesn't support in my device.
    so please help me. i want to play immortals in my device.
    05-15-2015 12:31 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Does it say you can't update because you're modified, or does it say you're already up to date?
    05-15-2015 12:51 AM

Similar Threads

  1. Replies: 1
    Last Post: 01-25-2016, 03:59 PM
  2. Replies: 1
    Last Post: 05-14-2015, 10:58 PM
  3. Replies: 1
    Last Post: 05-14-2015, 10:26 PM
  4. Replies: 1
    Last Post: 05-14-2015, 10:24 PM
  5. Replies: 0
    Last Post: 05-14-2015, 09:43 PM
LINK TO POST COPIED TO CLIPBOARD