1. AC Question's Avatar
    In the past it was not like that, even on the android 5.0.2. My mobile is completely locked with my patter and the screen does not even light up,its still black during the notification of an upcoming call. I must unlock it to receive a call whether by pin lock, patter or whatever security methods.
    Any suggestions please ?
    05-24-2015 01:56 AM
  2. RohanD6503's Avatar
    I found the solution after thorough research on the net, just go to <settings> <apps> <all> <IncallUI> click on Force stop,then enable it again. It did unlock my phone on swipe for incoming calls. By the way, the notification tick should always be on !
  3. B. Diddy's Avatar
    Welcome to Android Central! Are these regular mobile calls, are you using an app like Hangouts Dialer or Skype to receive calls?
    05-24-2015 05:44 PM
  4. RohanD6503's Avatar
    Thank you for your prompt reply, Yes they are regular phone calls. I am using the phone dialler to make calls !
    05-28-2015 11:18 AM
  5. B. Diddy's Avatar
    That's strange. Open the Phone app, tap Menu>Settings, then check all of the Call Settings to see if there are any related options.
    05-28-2015 05:17 PM
  6. RohanD6503's Avatar
    I did checked, There are no related options on the phone dialler or call settings. However I checked my display options, the phone is on sleep after 2 mins of inactivity ie it locks afer 2 mins of inactivity. Is this the reason why I have to unlocked it to receive calls ?
    05-29-2015 12:38 AM
  7. Kelly Kearns's Avatar
    I did checked, There are no related options on the phone dialler or call settings. However I checked my display options, the phone is on sleep after 2 mins of inactivity ie it locks afer 2 mins of inactivity. Is this the reason why I have to unlocked it to receive calls ?
    It shouldn't cause this issue. I have mine set on secure lock after 10 minutes (I use fingerprint) and I never have to unlock it to answer a call..

    Are you using a launcher?
    05-29-2015 01:01 AM
  8. B. Diddy's Avatar
    No, that shouldn't happen. Even if the phone has a screenlock, you should still be able to swipe to answer it. In order to get to the homescreen from within the call or after the call, that's when you should have to enter your screenlock.
    05-29-2015 01:08 AM
  9. Kelly Kearns's Avatar
    Just found something..

    I just did a quick Google search for, android 5.0.2 have to unlock phone to answer call, and this seems to be a bug of 5.0.2. Now it isn't on every phone, but on various phones. Such as the Nexus 5 seems to do it and the Nexus 6 doesn't. There are several other phones that mention doing this.

    It seems like all of them also have to do the same thing to dismiss and alarm. It is supposed to be corrected in 5.1.
    B. Diddy likes this.
    05-29-2015 01:13 AM
  10. B. Diddy's Avatar
    Good detective work! But it must not have been a bug that showed up universally on those devices, since I never encountered it on my Nexus 5. I wonder if other 3rd party apps might also be involved.
    05-29-2015 01:22 AM
  11. Kelly Kearns's Avatar
    Good detective work! But it must not have been a bug that showed up universally on those devices, since I never encountered it on my Nexus 5. I wonder if other 3rd party apps might also be involved.
    Don't know..I found a guy that he and his girlfriend both have a Nexus 5 and it happens to both of them.

    Seems some with the Moto G, 2nd Gen were also having the problem.

    It could be similar to the bug I have in the "more settings" of my call settings. It shows a "network or sim error" when I go in there. It seems to be only AT&T branded phones, but it isn't all AT&T branded phones and it was present on KitKat, but wasn't reported as a known issue. It could be something just like that.
    05-29-2015 01:27 AM
  12. RohanD6503's Avatar
    I found the solution after thorough research on the net, just go to <settings> <apps> <all> <IncallUI> click on Force stop,then enable it again. It did unlock my phone on swipe for incoming calls. By the way, the notification tick should always be on !
    B. Diddy likes this.
    06-01-2015 01:20 AM
  13. B. Diddy's Avatar
    Thanks for letting us know your solution! Although IncallUI isn't on the app list for all devices (like on my Zenfone 2), so I wonder what would have to be done if this issue crops up on those devices.
    06-01-2015 10:44 AM

Similar Threads

  1. From Note 4 to Z3, anyone?
    By zkyevolved in forum Sony Xperia Z3
    Replies: 21
    Last Post: 07-23-2015, 12:10 AM
  2. why asus fonepad 7 and 8 2014 and 2015 version has no LTE ???????????
    By gfederline9 in forum General News & Discussion
    Replies: 1
    Last Post: 05-24-2015, 05:46 PM
  3. how do i get rid of t-trojan 25 on phone if message appear
    By ockert bronkhorst in forum Ask a Question
    Replies: 2
    Last Post: 05-24-2015, 08:37 AM
  4. Why does my Samsung Galaxy S4 get hot and shut down?
    By AC Question in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 05-24-2015, 05:48 AM
  5. how to fix authentication error on galaxy s6 edge
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-24-2015, 01:42 AM
LINK TO POST COPIED TO CLIPBOARD