1. qwerqwerqwerqwerqwerqwer's Avatar
    Exploring SDCard0 via the native File Manager or ES Explorer yields 'empty folder'. The phone believes the files are there still, as evidenced by the Settings/Storage info displayed, which shows accurately the amount of space remaining. But the files are not accessible.
    Why is SDCard0 internal storage 'empty' [yet not]?-screenshot00082.jpg

    On attempting to browse the SDCard0 storage using Droid Over Wifi, there are two error messages
    Error!*(12:58:40) Error reading directory: /storage/sdcard0
    Error!*(12:59:8) DroidOverWifi does not have permissions to read directory: /storage/sdcard0/Download.

    I've been running low on memory to install new apps, and hoped to reallocate some data to external storage. To that end I installed Towelroot, Link2SD, a root uninstaller and SuperSU. I used Towelroot to access normally inaccessible files in ES Explorer, but made no changes. I didn't change any of the partitioning or add or delete any files.

    There is an annoying Carrier bootup logo that I hoped to uninstall, but this uninstall was unsuccessful.

    The phone isn't writing to internal storage anymore either. It wasn't possible to access Viber images that are/were stored there, or to take and save a screenshot using the simultaneous power/volume down buttons..

    Running Android 4.3 on a Huawei Phone.

    How do I get the 'permissions' back for access to SDCard0 as per usual?
    06-01-2015 12:26 AM
  2. Rukbat's Avatar
    On attempting to browse the SDCard0 storage using Droid Over Wifi, there are two error messages
    Error!*(12:58:40) Error reading directory: /storage/sdcard0
    Error!*(12:59:8) DroidOverWifi does not have permissions to read directory: /storage/sdcard0/Download.
    Try WiFi File Transfer, but I think you'll get the same sort of problem.

    There is an annoying Carrier bootup logo that I hoped to uninstall, but this uninstall was unsuccessful.
    You can replace it (and it's more than just a jpg file), but you can't delete it.

    The phone isn't writing to internal storage anymore either.
    I hope you have everything backed up, because I don't think you can back up much now.

    But the solution is probably to reflash the 4.3 ROM, and hope it's a firmware problem, not a hardware problem. The first error message says that the file structure of at least sdcard0 (which is just a folder) is messed up. The second one is due to the fact that, since sdcard0's file structure is messed up, apps can't find out the permissions to the folders in it.

    Now, as to why this happened ... Towel Root works. Link2SD can't mess up too much unless you freeze the wrong system app (effectively having the phone eat its own firmware - but unfreezing it should fix the problem), and SuperSU just keeps track of which apps you've given permission to acquire root access. (In Linux, when you run su - which is what rooting is, putting su back on the phone [Google left it off for a reason] - you're asked for the root password every time you run a rooted app.) The uninstaller normally can't cause any problems, unless it's very poorly written. Then it could possibly cross-link a deleted file it's undeleting with a system file, causing all sorts of problems. But we'd probably have seen hundreds of posts that some particular undelete app is causing problems.

    So my analysis is left with 2 possibilities - a hardware problem in the storage chip (or its support circuitry) or something messed up sdcard0's file structure.
    06-01-2015 03:14 PM
  3. qwerqwerqwerqwerqwerqwer's Avatar
    Thank you for your ideas. The bootup thing is something like an animated gif. It flashes through background colour changes for about 10 seconds and uses about 15mb of memory, and I'm thinking that possibly my atttempts to be rid of it might have caused the damage to the file structure.

    So now to reflashing the 4.3 ROM. Can you refer me to some instructions on that? I'm hoping it can be done over the top of the existing ROM.
    06-16-2015 08:20 PM

Similar Threads

  1. Replies: 7
    Last Post: 02-16-2016, 03:56 PM
  2. Asus Messaging App will not send Photos
    By TheJastrom in forum ASUS ZenFone 2
    Replies: 10
    Last Post: 06-10-2015, 09:10 PM
  3. Auto brightness is funky
    By lrrowley in forum LG G4
    Replies: 5
    Last Post: 06-01-2015, 07:47 AM
  4. Why is not there a slimport HDMI for note 4 ?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-01-2015, 12:38 AM
  5. Why is my phone lagging?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 05-31-2015, 11:42 PM
LINK TO POST COPIED TO CLIPBOARD