1. AC Question's Avatar
    When i type in a new web page, it takes about one minute to load. But then once it finally does load, i can click through around on the page at normal speed. This is a new thing that just popped up a day or so ago. I don't remember installing any new apps or anything recently. I did a factory reset and the problem still persists. Is my wifi adapter dying or is there some settings i don't know about to fix this issue?

    Other devices on my wifi function at normal speed, it's not a problem with an actual slow internet connection.
    06-14-2015 03:49 PM
  2. Rukbat's Avatar
    1. Loading is done over the internet. Moving around the page is done on your phone. If there's lag between you and the server the page is on, it won't affect moving around the page.

    2. Why does it take a minute to load the page? There are a lot of possibilities. Slow or overloaded server. (CNN has actually crashed when there's hot breaking news because of the hundreds of millions of connections it's trying to handle at once - TurboTax came down one April 15th near midnight, and it took about 2 days to get it back up.) Slow internet path from your ISP or carrier (depending on whether you're on wifi or mobile data) to the server. Slow browser. Something wrong with your phone. Electrical interference in the area, causing noise, causing a lot of packet resends, slowing the connection's effective speed. (And those are just a few of the more common possibilities.)
    06-14-2015 04:34 PM
  3. Shai Hulud's Avatar
    Sorry I described it wrong. What i meant was once i get on to say CNN.com after about a minute load time, i can click through to articles at full speed. It's just initially loading any web page is excruciatingly slow.

    To me, this paints a picture that it has nothing to do with my internet speed or overloaded servers. My ISP is Comcast and is pretty fast, never had a problem with speed in the past and this only recently started. It is every page load and every web page.
    06-14-2015 05:20 PM
  4. Shai Hulud's Avatar
    I found a solution that worked, but it was from a thread on the S6 that was having the exact problem i was...

    Search the forum form "Why is my brand new S6 so slow on Wi-Fi?" for the solution (i can't post links yet)

    This solution worked. Not happy about having to run another app in the background but at least can browse the internet again...Remarkable that this was a solution for a S6 that worked on a nexus 7 2013...
    06-14-2015 05:46 PM

Similar Threads

  1. How to change preferances in an s4
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-17-2015, 07:50 AM
  2. Sent it back
    By laddie79 in forum Moto 360
    Replies: 7
    Last Post: 06-15-2015, 12:32 PM
  3. How does google play music work?
    By KelseyRo4 in forum Samsung Galaxy S6
    Replies: 4
    Last Post: 06-15-2015, 07:38 AM
  4. Replies: 3
    Last Post: 06-14-2015, 05:45 PM
  5. Replies: 1
    Last Post: 06-14-2015, 04:36 PM
LINK TO POST COPIED TO CLIPBOARD