1. AC Question's Avatar
    I have a GS6 with Android 5.1.1. (kernal: 3.10.31-5028597) After I got the update, I cannot stay connected to my 2014 Toyota Highlander OEM bluetooth. It worked fine until the update. I have unpaired/repaired the bluetooth, I downloaded a 3rd party app (Bluetooth Auto Connect), I took the car to Toyota to make sure my head unit had the most up to date software. It does.

    Nothing works. The car will still pair with the phone, but then drop the connection and will never reconnect.

    My moms phone, a Verizon GS6 with 5.0.2 works fine.

    Any way to revert to 5.0.2 or fix this problem? Your thoughts would be helpful.
    06-26-2015 12:37 PM
  2. Rukbat's Avatar
    You could flash a 5.0.2 ROM, you can't "revert" to an earlier ROM because it's no longer in your phone.

    Or you can put in a complaint to your Toyota dealer and ask them to pass it up the line, that their firmware no longer works with Android 5.1.1. Google comes out with updates faster than car manufacturers are used to handling (one a year is considered fast for a car - one bug fix every few months is no longer unusual for Android) - and there are changes being made to standards, so the phone has the latest version of Bluetooth and your car head unit no longer does.
    06-26-2015 03:26 PM
  3. Robert Boden's Avatar
    Hello. I have the same problem. My Samsung S6 will no longer pair with my 2015 Toyota Highlander's Bluetooth. It will initially connect. But when the car is requesting permission to access contacts and messages, the car doesn't seem to receive the signal from my phone, that the phone has Allowed permission.

    I have unpaired and wiped the Bluetooth cache and app data numerous times. Just looking for any other ideas.

    I have Lollipop version 5.1.1 as well. Any help would be welcome
    09-01-2015 09:25 PM
  4. kickingcans's Avatar
    I have the same problem. I have a GS6 (Kernal 3.10.61-51028597) running 5.1.1. This is my second GS6 as TMobile just sent me a new one in hopes of fixing this very problem. While it connected initially, after about 2 hours of drive time, it disconnected and would never reconnect. I have been to the Toyota dealership and gotten the newest software update for my 2014 Toyota Highlander Entune system (Model ID: 13TDDANA-EA01 Audio: 0831 Operating System: 0714). While I can get other phones running 5.1.1 to connect, I can't test to see if they stay connected. I have an appointment to (hopefully) replace the head unit, but I am not sure what other steps to try. Any suggestions?
    09-04-2015 04:24 PM
  5. Rukbat's Avatar
    Bluetooth is a pipe. What flows through the pipe, and what format it's in, isn't specified.

    If the car manufacturer didn't test the head unit firmware with an S6 running 5.1.1, there's no guarantee it'll work with one. Some day, Bluetooth data formats will be specified and maybe some manufacturers will even follow the specs. Not all manufacturers follow industry specs.

    (Bluetooth isn't that big a problem. At one time you couldn't text a picture to someone on a different carrier.)
    09-04-2015 11:45 PM
  6. kickingcans's Avatar
    Bluetooth is a pipe. What flows through the pipe, and what format it's in, isn't specified.

    If the car manufacturer didn't test the head unit firmware with an S6 running 5.1.1, there's no guarantee it'll work with one. Some day, Bluetooth data formats will be specified and maybe some manufacturers will even follow the specs. Not all manufacturers follow industry specs.

    (Bluetooth isn't that big a problem. At one time you couldn't text a picture to someone on a different carrier.)

    Rukbat - I am not sure how this is helpful? What do you mean? Can you clarify?
    09-05-2015 09:24 AM
  7. Akin Pala's Avatar
    I have the same problem with my samsung gear circle. After 5.1.1. update, it connects to it but drops the connection when I move it slightly away from phone. Connects again, but then drops again. No problem with the car though. My wife's phone is 5.0 and her phone is working with the same headphones no problem.
    09-28-2015 03:47 AM
  8. thehobler's Avatar
    Same Problem with Droid Turbo and 2013 Honda CRV running 5.1. Phone works fine until I try to use "Contact Sharing". Then the intermittent disconnects start. Have to reset everything and start over from pairing. When asked to share contacts or messages I need say no to have the phone work without disconnecting. This defeats the purpose of "hands free". What's the solution? By the way the help screen on the phone has a "solution" but what it says to do does not exist on the phone. It says to check the "always allow" button, but there is no such button. Frustrating! Help?
    11-13-2015 10:58 AM
  9. kickingcans's Avatar
    Just by way of an update, after battling with the phone, Toyota, and Tmobile to find a solution, I finally broke down and bought a Iphone 6s. Connects and stays connected from day one. No problems.

    Sorry to report, but I have my old Samsung Galaxy S6 sitting in a drawer.
    05-04-2016 03:56 PM
  10. B. Diddy's Avatar
    If any of you have power saving modes turned on, try turning them off and see if that makes a difference.
    05-04-2016 04:23 PM

Similar Threads

  1. How do I know that my phone has been hacked?
    By Prem Naga in forum Android 4.4 KitKat
    Replies: 5
    Last Post: 06-14-2016, 01:54 AM
  2. Replies: 2
    Last Post: 09-04-2015, 11:47 PM
  3. My phone keeps restarting?
    By Spinxer in forum Ask a Question
    Replies: 1
    Last Post: 06-30-2015, 07:01 AM
  4. Unable to access files on Nexus 5 when connected to the PC
    By virenderknarang in forum Google Nexus 5
    Replies: 1
    Last Post: 06-30-2015, 06:56 AM
  5. Why is my tab stuck at the boot screen?
    By Jayden Smith2 in forum Samsung Galaxy Tab4 7.0
    Replies: 1
    Last Post: 06-30-2015, 06:54 AM
LINK TO POST COPIED TO CLIPBOARD