1. AC Question's Avatar
    Hey everyone! I would appreciate any info you can provide for me to solve this problem with my Galaxy tab s 10.0. I'm having some battery issues...

    1. My battery meter was reading about 40% so I charged it overnight for approximately 8 to 10 hours. When I went to use it the next morning it had only reaching about 85%, I thought for sure that it would have been fully charged.

    2. If the batter meter gets low and you plug the device in and continue to use it the battery still depletes, not as fast if if wasn't plugged in at all, but still decreases in overall battery power remaining. This is without running dual applications at the same time and without watching videos either.

    Just wondering if there is any insight out there as to how to solve these issues. I haven't even had it for a year yet and have contemplated sending it back to Samsung for a new one, which I'm not opposed to doing if need be.

    Thanks!
    07-07-2015 03:59 PM
  2. belodion's Avatar
    Welcome to Android Central.

    The USB lead may be faulty, or the USB port damaged or dirty. Check those first before considering other possibilities.

    Posted via the Android Central App
    07-07-2015 05:00 PM

Similar Threads

  1. Replies: 1
    Last Post: 07-07-2015, 05:41 PM
  2. Replies: 2
    Last Post: 07-07-2015, 05:31 PM
  3. Replies: 1
    Last Post: 07-07-2015, 05:04 PM
  4. What does the red triangle with exclamation point mean?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 07-07-2015, 04:15 PM
  5. S4 Samsung Skype Contact Issue
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 07-07-2015, 03:28 PM
LINK TO POST COPIED TO CLIPBOARD