1. AC Question's Avatar
    I'm using a Galaxy S, model # SPH-D700, Firmware 2.3.6, build Gingerbread.FC09, hardware D700.0.5.

    When I try to open Snapchat, I get an error that the version I have is not compatible with my operating system. But when I try to update Snapchat, I get an error that it is not compatible with my device.

    Is there a newer version of the operating system that I can download, or am I going to have to buy a new phone in order to use Snapchat?
    07-12-2015 05:55 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! I don't believe there's anything official for that phone, so you'd have to root the phone and look for a custom ROM specifically developed for the phone. I don't see anything in the AC forums: Epic 4G Rooting, ROMs, and Hacks - Android Forums at AndroidCentral.com
    07-12-2015 11:08 PM

Similar Threads

  1. Replies: 16
    Last Post: 09-02-2016, 02:09 PM
  2. Using the G4 with small hands
    By iamloco724 in forum LG G4
    Replies: 17
    Last Post: 07-18-2015, 10:03 AM
  3. Replies: 5
    Last Post: 07-16-2015, 05:55 PM
  4. How do I read messages that have a DOWNLOAD button?
    By Fred1960 in forum Samsung Galaxy S4
    Replies: 3
    Last Post: 07-13-2015, 08:05 AM
  5. How do I downloading an audiobook cd to my Samsung Tablet?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 07-12-2015, 04:41 PM
LINK TO POST COPIED TO CLIPBOARD