1. AC Question's Avatar
    I've had my galaxy s6 edge for about 6 months now and I love it. However yesterday I had my first problem. My fast charging option doesn't work. I plugged in my fast charger and my phone keeps telling me it's slow charging and that I should plug in my original charger. And the problem is not within the cord or box because I used my mom's fast charger and still have the same problem. My phone is at 54% right now and it won't be fully charged for another 3 hours. How/what can I do to get my fast charging back?
    08-11-2015 12:59 AM
  2. the tall guy's Avatar
    Might sound silly, but have you made sure the charger is fully inserted into the phone, is the USB cable fully plugged into the wall charger and is the charger the one that came with the phone?

    There has been a few posts about this issue, but more times than not the actual person querying it has had to get their phone replaced.

    Try using your charger on another phone that uses fast charging, if it works then it's more than likely going to be an issue with your phone.
    08-11-2015 02:23 AM

Similar Threads

  1. Batterry draining too fast
    By wrigduo in forum Sony Xperia Z3
    Replies: 2
    Last Post: 08-11-2015, 01:38 PM
  2. Moto X (2nd) ringtone: Can use any MP3 (e.g. copied from PC)?
    By albondiga in forum General Help and How To
    Replies: 2
    Last Post: 08-11-2015, 04:26 AM
  3. Why can I send texts but not recieve them?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-11-2015, 12:24 AM
  4. How do I downgrade my Moto E X1022 from Lollipop to KitKat?
    By Meenu Garg in forum General Help and How To
    Replies: 0
    Last Post: 08-11-2015, 12:11 AM
  5. Galaxy-Grand Neo, Battery Disconnected Error
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-11-2015, 12:08 AM
LINK TO POST COPIED TO CLIPBOARD