1. AC Question's Avatar
    Just recently, when using our handheld android devices on our home wifi network, it takes far, far more time refresh and load images on apps such as instagram and facebook.

    Seems when an app is opened the devices stall for a good 30 seconds, then slowly load images. A quick switch over to cell 4g or even 3g will instantly load the images and sadly out performs our wifi any day of the week. Bizarre that it only seems to be images? Maybe due to the size...

    Anyway, what boggles my mind is that speed tests show acceptable/consistent ping (20ms) and DL (50mbps) /UL (6-10mbps) speeds... so I feel like it's some other hangup with the gateway communicating initially or the devices/apps?

    I've seen this problem out there, but not a lot of good solutions. Starting to drive me crazy.

    More info; devices are Samsung S3's (android 4.4.2) using a Mediacom supported/rented gateway/wifi (50mbps). No router. Internet settings etc haven't changed.
    08-24-2015 01:42 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Review this guide and see if the tips help: [GUIDE] Troubleshooting Wi-Fi Connection Problems. You can probably find the manual for your Mediacom modem/router online, so that you can figure out how to log into its settings.
    08-24-2015 06:23 PM
  3. Rukbat's Avatar
    Check the router (connect to it with a browser). Look in the wireless section, for the encryption method. If it's TKIP or TKIP+AES, change it to AES. (Then forget the connection and connect again. All devices will have to do this.) Some implementations of TKIP (Linksys is really bad - even AES doesn't work - I had to buy a cheap Netgear WNR2000 for my wife to be able to keep using Facebook) don't work with Android.

    Standards are a great thing - but when different companies use different "standards" they're no longer standards.
    B. Diddy likes this.
    08-24-2015 06:55 PM

Similar Threads

  1. Replies: 16
    Last Post: 08-30-2015, 11:38 PM
  2. [SOLVED] After moving photos to SD card, cant seem them on Gallery.
    By shiflerg in forum Verizon Samsung Galaxy S4
    Replies: 5
    Last Post: 08-25-2015, 10:38 AM
  3. Why can't I setup my Android for wifi?
    By AC Question in forum General Help and How To
    Replies: 2
    Last Post: 08-25-2015, 12:08 AM
  4. Battery Life on Fi & Battery stat for time without a signal
    By ryancell in forum Google Project Fi
    Replies: 1
    Last Post: 08-24-2015, 08:21 PM
  5. Replies: 0
    Last Post: 08-24-2015, 01:33 PM
LINK TO POST COPIED TO CLIPBOARD