1. Ed31's Avatar
    So everyone of my friends is using the new Snapchat filters or lens on their Galaxy S4 and iPhones and I can't use any of them. It says on the "What's New" that only new Android devices can get this. I think 5.0.2 Lollipop isn't that old...
    09-27-2015 02:53 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! It'd probably be best to contact Snapchat support about this: https://support.snapchat.com/
    09-27-2015 04:54 PM
  3. bahrin's Avatar
    So everyone of my friends is using the new Snapchat filters or lens on their Galaxy S4 and iPhones and I can't use any of them. It says on the "What's New" that only new Android devices can get this. I think 5.0.2 Lollipop isn't that old...
    06-13-2016 02:29 PM

Similar Threads

  1. Replies: 2
    Last Post: 10-09-2015, 10:29 AM
  2. New Nexus 6 - Root Now or Wait?
    By jcc27 in forum Google Nexus 6
    Replies: 3
    Last Post: 09-28-2015, 12:07 AM
  3. Replies: 1
    Last Post: 09-27-2015, 04:57 PM
  4. Replies: 1
    Last Post: 09-27-2015, 04:55 PM
  5. Replies: 1
    Last Post: 09-27-2015, 03:56 PM
LINK TO POST COPIED TO CLIPBOARD