1. AC Question's Avatar
    So I got a Galaxy A3 and, if I am right (sorry I reeeally have never looked into such things), the Android system is 4.2 or something.

    But then why I can't download some apps that requires the 2.3 version or above? for example, "Dattch" or "Lloyds Bank".

    The app store simply tells me that the device is not compatible and bye bye. Help?
    09-28-2015 03:15 PM

Similar Threads

  1. Why is the Samsung s4 mini so poo?!
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-28-2015, 07:48 PM
  2. Why is my Note 5 battery draining so fast?
    By AC Question in forum Samsung Galaxy Note 5
    Replies: 1
    Last Post: 09-28-2015, 07:42 PM
  3. Why is my LG G3 screen fading to black?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-28-2015, 07:38 PM
  4. Why can't I uninstall the Facebook app?
    By AC Question in forum Samsung Galaxy S6
    Replies: 0
    Last Post: 09-28-2015, 03:10 PM
  5. How can I delete emails that are still showing up under my DRAFT folder?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 09-28-2015, 03:04 PM
LINK TO POST COPIED TO CLIPBOARD