1. AC Question's Avatar
    Hi, guys!
    It's been about 24h since I had purchased my Moto X (Unlocked), and I've already broken ip :P
    So here's the story of my unit:
    From the box it came with 5.x, i've been using it for roughly two-three hours with Telus sim, everything was totally fine.

    Then I got myself into a situation, where I wanted to install CM12. So I did, everything was fine (except for the battery life), and I went to sleep.

    First thing in the morning, I wanted to try something new (Flyme OS). And there the stuff went wrong. I wanted to do a full wipe of the phone.
    I did it, by manually erasing each partition one by one.
    Then I had several attempts of installing it, having them all failed. At this point, I had realized that I don't want to install it anymore, so I have downloaded the stock firmware and flashed it up with this sequence:
    fastboot oem fb_mode_set
    fastboot flash partition gpt.bin
    fastboot flash motoboot motoboot.img
    fastboot flash logo logo.bin
    fastboot flash boot boot.img
    fastboot flash recovery recovery.img
    mfastboot flash system system.img
    fastboot flash modem NON-HLOS.bin
    fastboot erase modemst1
    fastboot erase modemst2
    fastboot flash fsg fsg.mbn
    fastboot erase cache
    fastboot erase userdata
    fastboot erase customize
    fastboot erase clogo
    fastboot oem config carrier vzw !!! (was not sure that this was right)
    fastboot oem fb_mode_clear

    HOWEVER! On my first attempt, modem file was not right (as my phone was continuously rebooting on first setup (while choosing wifi network).

    The second attempt with different NON-HLOS.bin file went ok, wifi is working like charm.

    BUT now there is no cellular connection at all! I have tried two SIM (Telus and Megafon, which both work inside my iPhone 6)

    At this point I'm totally stuck and desperately ask for your help
    10-02-2015 06:30 PM

Similar Threads

  1. How long did your 16/2 Moto G take to arrive?
    By Basis in forum Moto G (2015)
    Replies: 5
    Last Post: 01-18-2016, 01:45 AM
  2. Replies: 1
    Last Post: 10-28-2015, 04:34 PM
  3. No WIFI Connection
    By RicKaysen in forum Moto X Pure Edition
    Replies: 6
    Last Post: 10-15-2015, 05:40 PM
  4. Will Visa Prepaid cards work with Android Pay?
    By TechFanLolz in forum Ask a Question
    Replies: 1
    Last Post: 10-02-2015, 06:22 PM
  5. Will a Verizon SIM work in Nexus 6p?
    By Zekzem in forum Ask a Question
    Replies: 0
    Last Post: 10-02-2015, 05:58 PM
LINK TO POST COPIED TO CLIPBOARD