1. AC Question's Avatar
    The Google voice typing option in 'Language and input' has disappeared on my Galaxy S6, lollipop 5.1.1. I don't have a microphone icon on the standard Samsung keyboard. My Google app is enabled, and I can use the voice activated "OK google" function from the search bar on my home page, but I would like to enable the talk to text function in messaging.
    Thanks.
    10-06-2015 09:55 AM
  2. LGT-Tech's Avatar
    If missng the mic on the keyboard for speech to text.. and the google voice typing option is missing under languange and input.. This is how I finally fixed it:

    Settings > Language and Input > Default > Add Keyboards > check Google Voice Typing.
    bward11 likes this.
    10-06-2015 05:06 PM
  3. stmiranda's Avatar
    If missng the mic on the keyboard for speech to text.. and the google voice typing option is missing under languange and input.. This is how I finally fixed it:

    Settings > Language and Input > Default > Add Keyboards > check Google Voice Typing.
    Hello,

    I'm having the same issue. Google keyboard is okay but no microphone with the Samsung keyboard. Google Voice Typing is enabled.

    Apps in My KNOX launch the Samsung keyboard despite the Google keyboard being set as default.

    Thanks

    Posted via the Android Central App
    Hbcgirl likes this.
    12-16-2015 07:07 PM
  4. stmiranda's Avatar
    Figured out how to enable Google keyboard so I'm good. Though I'd still be interested nin figuring this out.

    Thanks

    Posted via the Android Central App
    12-16-2015 07:14 PM
  5. Roger Dunn's Avatar
    Here's how I fixed it on my Samsung Galaxy S6 after the Marshmallow Update. In Settings > Language & Input > Default Keyboard > Set up input methods > and finally saw Google Voice Typing, which was off. After turning it on, only then does the Language & Input screen show Google Voice Typing as an option there. After getting back to the Samsung keyboard (in messaging or memo or whatever) press and hold the gear button and switch to the microphone button. To turn your voice into text, tap that mic!

    You'll notice that symbols are under different keys with Marshmallow. Comma used to be under v, but is now under x. Exclamation point used to be under d, but is now under a. Etc.

    I don't remember turning that Voice option off. Must have been the Marshmallow Update. Thanks for leading me down the correct path, everyone!
    Hbcgirl likes this.
    04-11-2016 09:40 AM
  6. Alan Mitchael's Avatar
    Finally found sure Fix! First, make sure you haven't disabled Google Search. Once you're sure of that, go to Settings/Language&Input. Tap where it says "Current Keyboard: Google Keyboard" and then a pop-up will appear with an option that says 'Choose Keyboards', tap on that, then you will finally find the 'Google Voice Typing' switch, turn it on.
    Now, when you go to Keyboard Options, the 'Google Voice Typing Key' or Mic button will be fully functional.
    05-17-2016 11:42 PM
  7. duke6024's Avatar
    6.0 lollipop note 5 I found it Google keyboard preferences voice ON.
    06-08-2016 06:24 PM
  8. Lance Earl's Avatar
    Here's how I fixed it on my Samsung Galaxy S6 after the Marshmallow Update. In Settings > Language & Input > Default Keyboard > Set up input methods > and finally saw Google Voice Typing, which was off. After turning it on, only then does the Language & Input screen show Google Voice Typing as an option there. After getting back to the Samsung keyboard (in messaging or memo or whatever) press and hold the gear button and switch to the microphone button. To turn your voice into text, tap that mic!

    You'll notice that symbols are under different keys with Marshmallow. Comma used to be under v, but is now under x. Exclamation point used to be under d, but is now under a. Etc.

    I don't remember turning that Voice option off. Must have been the Marshmallow Update. Thanks for leading me down the correct path, everyone!
    Thank you for the fix Roger!
    Lance Earl
    07-16-2016 07:20 AM
  9. DroidDawgS4's Avatar
    Thanks to all for the helpful suggestions. On my Note 7, I found that I had to install the Google Keyboard from the Play Store first because, OOB, it would not let me select the Google keyboard as the default. As a result, the Samsung keyboard would override every other input method. Even now, I have to set the Google keyboard as the default. Otherwise, Samsung voice input will override Google's and will NOT let me use Google voice input. This is, of course, unacceptable because Google's voice recognition is much, much better than Samsung's. If anyone has a more acceptable/permanent fix, that would be great.
    08-25-2016 03:20 PM
  10. DroidDawgS4's Avatar
    Thanks to all for the helpful suggestions. On my Note 7, I found that I had to install the Google Keyboard from the Play Store first because, OOB, it would not let me select the Google keyboard as the default. As a result, the Samsung keyboard would override every other input method. Even now, I have to set the Google keyboard as the default. Otherwise, Samsung voice input will override Google's and will NOT let me use Google voice input. This is, of course, unacceptable because Google's voice recognition is much, much better than Samsung's. If anyone has a more acceptable/permanent fix, that would be great.
    So, after digging a bit deeper, it looks like Samsung has disabled Google Voice Input for the N7 and replaced it with Samsung Voice Input only. If anyone can think of an easy way around that, it would be great.
    08-25-2016 04:39 PM
  11. davidweaver2's Avatar
    So, after digging a bit deeper, it looks like Samsung has disabled Google Voice Input for the N7 and replaced it with Samsung Voice Input only. If anyone can think of an easy way around that, it would be great.
    Yes, same problem with Note 7 stuck with Samsung Voice (which is full of mistakes and super slow) and no Google voice option. Help please!! Thanks!
    08-30-2016 11:06 AM
  12. Wooldog 88's Avatar
    I recently got a galaxy s7 and couldnt find the mic button anywhere. It turns out i didabled a bunch of apps when i got it. The google app was one of them. Make sure the google app is enabled in the play store.
    09-11-2016 07:22 AM
  13. mgdanto's Avatar
    My solution was embarrassingly simple. I didn't realize that I could press and hold the emoji icon to switch back to mic. I guess it may be an issue when upgrading to a new phone and not being familiar with the new OS. Anyway, just thought I'd throw it out there as a solution for some.
    09-11-2016 11:18 AM
  14. paulabr0814's Avatar
    On the bottom row of the keyboard, there is a "settings" symbol, second key in from the left. Press and hold it and three options will pop up. One is for settings, one is for your clipboard of recent items copied, and the third is for the microphone for voice input. One you select it it will remain the default until you change it again to one of the other options.
    12-11-2016 10:00 AM

Similar Threads

  1. Wish Google card would work with Samsung Pay
    By dadathepanda in forum Samsung Pay
    Replies: 4
    Last Post: 10-07-2015, 09:03 PM
  2. Replies: 1
    Last Post: 10-06-2015, 09:31 AM
  3. Replies: 2
    Last Post: 10-06-2015, 09:23 AM
  4. Here's a fix for Note 4 Voice to Text freezing
    By okiebirdnerd in forum General Help and How To
    Replies: 2
    Last Post: 10-06-2015, 03:34 AM
  5. Why I'm I getting unfortunately your Google had stoped
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-06-2015, 01:30 AM
LINK TO POST COPIED TO CLIPBOARD