1. jaytee1986's Avatar
    Hi

    For about a week now certain apps won't work when my S5 is connected to 3G. They work perfectly on wifi but when I try on 3G the H+ symbol will change to H over and over again and the arrows will constantly flash.

    Any help would be appreciated.

    Thanks

    Posted via the Android Central App
    10-06-2015 02:43 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Does anything work on 3G, like the browser? Have you checked with your carrier to see if there's a problem with the network in your area?
    10-06-2015 03:02 PM
  3. jaytee1986's Avatar
    Thanks for the reply

    Yes the browser works fine. Every now and then it seems to go to sleep loading a page I just reload the page and it's fine.

    I plan to check with Virgin tomorrow but the way the browser works and other apps it seems like a connection issue.

    Thanks

    Posted via the Android Central App
    10-06-2015 03:05 PM
  4. B. Diddy's Avatar
    If 3G is really slow, some apps might timeout before they finish loading whatever they were trying to load.
    10-06-2015 04:07 PM

Similar Threads

  1. Why doesn't my S6 work in China?
    By AC Question in forum Samsung Galaxy S6
    Replies: 3
    Last Post: 10-06-2015, 09:50 PM
  2. Music on SD card won't play on Huawei Ascend Mate 2
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 10-06-2015, 04:06 PM
  3. How do i downgrade from lollipop to KitKat on my hudl 2?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-06-2015, 03:38 PM
  4. My Samsung Galaxy does not let me swipe the screen at all, why?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 10-06-2015, 03:25 PM
  5. Samsung Galaxy S3 No OS Installed - Rooted - Doesn't Boot
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 10-06-2015, 02:16 PM
LINK TO POST COPIED TO CLIPBOARD