1. saffamagic1986's Avatar
    I have a Samsung Galaxy A3 running Android 4.4.4. In the past 2 months its been really good with battery life, lasting for 2 days at most but as of yesterday it goes flat by 50% in 5 hours, just happened all of a sudden. I only have facebook, twitter and candy crush. Nothing else really so I dont understand why its happened all of a sudden as I have not had any new apps added. Please could someone help me as I just dont understand...
    10-16-2015 03:56 PM
  2. UJ95x's Avatar
    Welcome to AC!
    Can you check your battery stats and tell us what's showing as the biggest drain? Or could you post screenshots of those?
    saffamagic1986 likes this.
    10-16-2015 03:59 PM
  3. saffamagic1986's Avatar
    Android System - 24%
    Screen - 16%
    Android OS 12%
    Google Services 12%
    Candy Crush Saga 7%
    Messenger 4%
    Facebook 3%
    Cell Standby 3%
    Phone 3%
    10-16-2015 04:07 PM
  4. UJ95x's Avatar
    Android System - 24%
    Screen - 16%
    Android OS 12%
    Google Services 12%
    Candy Crush Saga 7%
    Messenger 4%
    Facebook 3%
    Cell Standby 3%
    Phone 3%
    What's your signal like where you live/work/etc?
    10-16-2015 06:03 PM
  5. saffamagic1986's Avatar
    Normally quiet good, never have problems getting texts or calls. I would say between 40% and 60% signal most of the time. No problems there really.
    10-16-2015 06:12 PM
  6. UJ95x's Avatar
    Normally quiet good, never have problems getting texts or calls. I would say between 40% and 60% signal most of the time. No problems there really.
    Hmm, OK. Do you have location services enabled on your phone?
    10-16-2015 07:24 PM
  7. saffamagic1986's Avatar
    My location services are never on unless I use my google maps but that is very rare...
    10-18-2015 09:36 AM
  8. UJ95x's Avatar
    Just curious, did you wipe the cache partition on your phone after updating to 5.1.1?
    10-18-2015 06:03 PM
  9. saffamagic1986's Avatar
    My software is still 4.4.4 though. Should I delete the cache then?
    10-19-2015 02:46 PM
  10. UJ95x's Avatar
    My software is still 4.4.4 though. Should I delete the cache then?
    Whoops. Not sure why I thought you were on 5.1. Sorry about that

    But yes, try doing that anyway. I do it about once a month to make sure everything is in working order
    10-21-2015 09:38 AM

Similar Threads

  1. Replies: 1
    Last Post: 10-17-2015, 03:11 AM
  2. Email sync issues
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-17-2015, 03:06 AM
  3. Why is my battery life draining?
    By kristian123 in forum Batteries
    Replies: 2
    Last Post: 10-16-2015, 05:44 PM
  4. (5.1.1.) Forced Update, Battery DrainGate
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-16-2015, 04:03 PM
  5. Replies: 2
    Last Post: 10-16-2015, 03:57 PM
LINK TO POST COPIED TO CLIPBOARD