1. Whydoihavetoregistertopost's Avatar
    Try as I may I can't get the charger cable head to stay securely in the Mophie pack.
    It keeps disconnecting and reconnecting (with the accompanying annoying beep every minute or two - "charger connected" and "fast charger connected")
    It gets so bad that I have to take off the Mophie to charge efficiently.
    My cables and phone are new and in good condition.
    Any tips or advice?
    Or have others had this problem?
    I have tried with different chargers and heads, all to differing degrees of inefficiency to as bad as full failure.

    Posted via the Android Central App
    10-24-2015 08:52 AM
  2. Golfdriver97's Avatar
    Welcome to the forums. I'm curious if the charging connection on the pack to the phone was made in error, as in it wasn't manufactured correctly. Could possibly be a lemon unit. How long have you had the pack? Have you contacted Mophie about this?
    10-24-2015 09:31 AM
  3. Whydoihavetoregistertopost's Avatar
    Thanks for your concern.
    I have had it 3 months.
    It sort of works but is getting worse. It is as if the connecting bits are not firmly in.
    No I didn't contact Mophie.
    Guess I could try that.
    I tried their FAQS etc and no help.

    Posted via the Android Central App
    10-24-2015 11:24 AM
  4. Golfdriver97's Avatar
    It s worth a try if mophie has at least a 6 month warranty. Aside from that, I am not sure what to suggest.
    Laura Knotek likes this.
    10-24-2015 04:12 PM
  5. Whydoihavetoregistertopost's Avatar
    I was wondering if maybe there were longer "nibs" for the end of the charger cord.

    Posted via the Android Central App
    10-24-2015 07:16 PM
  6. Whydoihavetoregistertopost's Avatar
    I have since got more Mophie charger cables. They are a tiny bit longer. Many of my (cheap) generic cables do not work. Oh well just have to spend more.

    Posted via the Android Central App
    11-21-2015 08:30 AM

Similar Threads

  1. Files not visible in Windows 10 since Marshmallow update on Nexus 6?
    By ElronTheElder in forum Android 6.0 Marshmallow
    Replies: 34
    Last Post: 02-01-2017, 10:45 PM
  2. S4 Mini wont turn on
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-24-2015, 01:49 PM
  3. Replies: 1
    Last Post: 10-24-2015, 09:37 AM
  4. Replies: 0
    Last Post: 10-24-2015, 08:46 AM
  5. I can not update or download anything on my ZTE Phone
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 10-24-2015, 07:19 AM
LINK TO POST COPIED TO CLIPBOARD