1. AC Question's Avatar
    Need help I am having and echo on calls. I can only hear myself and it gets annoy. I have turned off the noise reduction and reset the phone but nothing helps..... Need help please !!!!!!!
    10-26-2015 08:10 PM
  2. Rukbat's Avatar
    Turn the volume down. If that doesn't do it, check with your carrier. (They can be causing echo on the backhaul (the link from the tower to the telephone system).
    10-27-2015 02:13 AM

Similar Threads

  1. Replies: 2
    Last Post: 10-27-2015, 10:33 AM
  2. My Developer Setting "Transition Animation" Keeps Turning Off
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 10-26-2015, 08:07 PM
  3. Fixed the haptic feedback
    By bigbadwulff in forum Motorola Droid Turbo
    Replies: 0
    Last Post: 10-26-2015, 08:06 PM
  4. Replies: 0
    Last Post: 10-26-2015, 07:50 PM
  5. Video playback issues on the Nexus 5x
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 10-26-2015, 07:48 PM
LINK TO POST COPIED TO CLIPBOARD