1. AC Question's Avatar
    I have a brand new S6 Active. No rooting, no Nothing. The phone is stock and I can't install Facebook because it says "Your device isn't compatible with this version." I tried going through play.google.com/store and see the same thing.

    Android Version 5.02

    I'm an Android Newbie, but already getting pretty frustrated by the number of roadblocks I need to workaround to get anything done.

    Any suggestions to Install Facebook? Other apps (Instagram, Messenger, Waze, etc. have had no issues)
    11-12-2015 09:36 PM
  2. Sportt's Avatar
    It's a Facebook thing and just started with their latest update a few days ago. Never been a problem before on my S6 Active.
    11-14-2015 10:00 AM
  3. B. Diddy's Avatar
    Welcome to Android Central! See this thread: Why won't my Galaxy S6 active let me download Facebook?. Closing this thread to prevent parallel discussions.
    11-15-2015 03:13 PM

Similar Threads

  1. Replies: 1
    Last Post: 11-26-2015, 04:04 AM
  2. Issue with adding a pic to a text message.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 11-26-2015, 03:59 AM
  3. Replies: 1
    Last Post: 11-26-2015, 03:58 AM
  4. How do I find the app for facebook on my Galaxy S6 Active?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 11-15-2015, 03:14 PM
  5. How to update my HTC M8 with Lollipop 5.2 ?
    By AC Question in forum HTC One M8
    Replies: 1
    Last Post: 11-12-2015, 08:34 PM
LINK TO POST COPIED TO CLIPBOARD