1. AC Question's Avatar
    Kogan Agora Lite with Lollipop 5.0.2

    Play Store says "Your device isn't compatible with this version"
    11-13-2015 05:36 AM
  2. belodion's Avatar
    Welcome.

    That message tells the whole story. It's explaining why you can't proceed.
    11-13-2015 06:23 AM

Similar Threads

  1. Replies: 1
    Last Post: 11-26-2015, 04:23 AM
  2. Help please! LG G3 - Play store white screen!
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 11-13-2015, 04:03 PM
  3. Why won't my HTC One S turn on?
    By AC Question in forum HTC One S
    Replies: 1
    Last Post: 11-13-2015, 03:56 PM
  4. Replies: 1
    Last Post: 11-13-2015, 06:28 AM
  5. Replies: 0
    Last Post: 11-13-2015, 05:07 AM
LINK TO POST COPIED TO CLIPBOARD