1. AC Question's Avatar
    Hi all,

    I have been using BLU Studio X from past 6 months and recently after the android 5.0.2 OTA, I am stuck with 2G. Whenever I try to force the network to access 3G only the carrier's signal is lost.

    I have checked all the APNs and everything is perfectly configured. I have also tested my sim in another phone and I was able to successfully connect to 3G.

    I have tried to reset my phone a couple of times and yet no luck on the same.

    Please help me out of this...!!!

    Thanks in Advance.
    11-14-2015 09:10 AM
  2. Rukbat's Avatar
    I had the same problem with a Note 3 after an update. Since it was the update that caused the problem, and reflashing the update wouldn't fix it, the carrier had to replace the phone (even though it was way out of warranty).
    11-16-2015 02:15 AM
  3. Ravi_Chandra's Avatar
    Hi dude,

    I am using a unlocked device and I dont think BLU would provide an OTA update anytime sooner. Any workarounds for this issue otherthan rooting/flashing?

    Thanks for the quick reply..
    11-16-2015 10:51 AM

Similar Threads

  1. Can I make my Samsung Z1[tizen os] Android?
    By miryala narmada in forum General Help and How To
    Replies: 3
    Last Post: 08-29-2016, 06:46 AM
  2. How do I reset the gmail to my LG G4 lte?
    By AC Question in forum LG G4
    Replies: 2
    Last Post: 11-16-2015, 02:20 AM
  3. Replies: 1
    Last Post: 11-16-2015, 02:18 AM
  4. When does the new model Kimchi Refrigerator come to the USA?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 11-14-2015, 09:22 AM
  5. Replies: 0
    Last Post: 11-14-2015, 09:07 AM
LINK TO POST COPIED TO CLIPBOARD