1. AC Question's Avatar
    I recently got a Moto x Pure and it's great, however once I turned on Wifi everything was slow and it'd often freeze and restart. I've tried wiping the app cache, however that doesnt seem to help at all.
    01-08-2016 12:29 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Does this happen on any wi-fi network, or just your home network? Is wi-fi calling an option for you, and if so, is it on or off?
    01-08-2016 06:01 PM
  3. 2Ghee's Avatar
    I've only been able to use my home network and wifi calling isn't an option
    01-09-2016 10:59 AM
  4. B. Diddy's Avatar
    Does it also happen in Safe Mode? https://motorola-global-portal.custh...41/kw/recovery
    01-09-2016 01:46 PM
  5. 2Ghee's Avatar
    Yes.
    01-09-2016 03:05 PM
  6. B. Diddy's Avatar
    The next step would be a factory reset. If that doesn't help, then there's either a hardware issue or a firmware issue.
    01-09-2016 04:50 PM
  7. 2Ghee's Avatar
    After doing a factory reset from recovery mode, my phone stopped reading my sim card, that was fixed by taking it in and out. Then I selected my wifi, however then after leaving the phone untouched for half a minute, it crashed and reset. I have tried to do this multiple times now, however the same problems seem to occur time and time again.
    01-16-2016 05:24 AM
  8. B. Diddy's Avatar
    The only other things I can think of would be to reinstall the firmware (not sure how easy that is with the X Pure--you'd have to look that up), or to contact Motorola if it's still under warranty.
    Laura Knotek likes this.
    01-17-2016 01:21 AM

Similar Threads

  1. Forgot screen lock password on my Samsung galaxy tablet
    By Nina bina in forum Samsung Galaxy Tab S2
    Replies: 4
    Last Post: 02-24-2016, 01:39 AM
  2. Why is my S5 the best phone I've yet owned?
    By scrondar in forum Samsung Galaxy S5
    Replies: 7
    Last Post: 01-12-2016, 07:24 AM
  3. Wifi disconnect/reconnect
    By Mike Pawka in forum Samsung Galaxy S5
    Replies: 11
    Last Post: 01-11-2016, 01:20 PM
  4. Slow disconnect notification
    By jcdub in forum LG Watch Urbane
    Replies: 4
    Last Post: 01-10-2016, 09:06 AM
  5. Why is my phone taking some long to update!
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-08-2016, 03:05 PM
LINK TO POST COPIED TO CLIPBOARD