1. AC Question's Avatar
    HELP! My Galaxy S5 wont play any of my videos in my galary. I've tried deleting multiple videos and pictures and nothing works. I am connected to wi-fi at all times and it just doesn't seem to do anything. It's so frustrating! Please help me...
    01-31-2016 12:45 AM
  2. Laura Knotek's Avatar
    Hi there,

    Are these streaming videos from YouTube, Netflix, etc., or are they videos that you have stored on your device?

    What apps are you using to play the videos?

    If they are videos that you have stored on your device, what format are they?
    01-31-2016 12:48 AM
  3. Kileycrawford99's Avatar
    They are videos I have personally made and saved. Not from YouTube or anything of the sort. I go to the galary to open it up and play it but it says "Can't play video" they are saved as mp4's if that makes sense.
    01-31-2016 01:11 AM
  4. Laura Knotek's Avatar
    Thanks for your response. I will see if other folks who are Samsung users will be able to help you.
    01-31-2016 01:32 AM
  5. B. Diddy's Avatar
    Welcome to Android Central! There have been some discussions about a recent Google+ update causing some problems with videos. Try uninstalling Google+ (or uninstalling updates), then reinstalling.
    Laura Knotek likes this.
    01-31-2016 02:06 AM
  6. Kileycrawford99's Avatar
    Thank you it worked
    B. Diddy likes this.
    01-31-2016 08:10 AM
  7. roxetak's Avatar
    Samsung galaxy S4 got a problem play videos attached like messege. I try play in fb app and messenger. Still wont play
    02-02-2016 12:00 PM
  8. B. Diddy's Avatar
    Samsung galaxy S4 got a problem play videos attached like messege. I try play in fb app and messenger. Still wont play
    Welcome back! Did you already try what was suggested above?
    02-02-2016 05:55 PM
  9. leon3357's Avatar
    Hello, I'm having the same problems with my S4. Any videos I try to watch on fb will play for app. 2-3 seconds then freeze. I can watch videos on you tube or google. I unistalled/installed fb but still locking up videos. I would think it is some type of settings issue (?) but would like some suggestions for a remedy. Thanks!
    02-25-2016 08:27 AM
  10. roxetak's Avatar
    Yes, offcourse. I tried it
    04-19-2016 10:22 PM

Similar Threads

  1. Moto X Play and Marshmallow woes
    By tomb1935 in forum Moto X Play
    Replies: 3
    Last Post: 02-28-2016, 04:08 PM
  2. Replies: 1
    Last Post: 02-25-2016, 12:14 PM
  3. Replies: 1
    Last Post: 02-25-2016, 12:07 PM
  4. Lock Booster app is not getting uninstalled
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-25-2016, 12:06 PM
  5. Replies: 1
    Last Post: 02-25-2016, 11:57 AM
LINK TO POST COPIED TO CLIPBOARD