1. AC Question's Avatar
    Ive read the thread on the wifi and BT. Ive turned BT off, turned phone off, did just about everything except factory reset. Signal strength is showing very good, cant do a single thing on the internet when connected to my network. As soon as I turn wifi off, connects and opens google instantly.
    03-15-2016 05:06 PM
  2. sydneycooper1979's Avatar
    Have you tried resetting your home router?
    03-15-2016 07:01 PM
  3. itguyjax8430's Avatar
    Ive read the thread on the wifi and BT. Ive turned BT off, turned phone off, did just about everything except factory reset. Signal strength is showing very good, cant do a single thing on the internet when connected to my network. As soon as I turn wifi off, connects and opens google instantly.
    Welcome to Android Central!


    My S7 Edge works perfectly on my Asus router at home. Try changing your security settings on your router to see if that is the issue. Also try rebooting the router.
    03-15-2016 07:02 PM

Similar Threads

  1. Where is the Game Launcher?
    By Knowledge10111 in forum Samsung Galaxy S7 edge
    Replies: 17
    Last Post: 01-14-2017, 10:43 AM
  2. Replies: 2
    Last Post: 03-20-2016, 12:25 PM
  3. How to get rid of "Car Mode" on s5.
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-15-2016, 05:04 PM
  4. Why won't all my photos show on windows explorer?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-15-2016, 05:03 PM
  5. Recording at concerts with the S7
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-15-2016, 04:53 PM
LINK TO POST COPIED TO CLIPBOARD