1. AC Question's Avatar
    when I try to install the Samsung Internet browser Google Play says it is not compatible with my phone even though I am running Lollipop OS
    03-28-2016 08:22 PM
  2. H3aTeRzz's Avatar
    Thanks for stopping in!

    Are you trying to install, or update it? Isn't the browser you're trying to install, the default one that came on the phone?
    03-28-2016 09:24 PM

Similar Threads

  1. HTC One M8 won't re-pair to my LG sound bar
    By mzottola in forum HTC One M8
    Replies: 5
    Last Post: 03-28-2016, 09:19 PM
  2. help I want to love my phone not hate it
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-28-2016, 08:06 PM
  3. Replies: 0
    Last Post: 03-28-2016, 07:55 PM
  4. Replies: 0
    Last Post: 03-28-2016, 07:35 PM
  5. Replies: 0
    Last Post: 03-28-2016, 07:21 PM
LINK TO POST COPIED TO CLIPBOARD